No master branch when creating a repository?

I'm sorry if this is a dumb question, I have never used any type of version control before. I signed up for bitbucket, went through their tutorial with source tree to modify the file and push it back to the repository and had no issues

After creating a repository for some java code on bit bucket (repository is empty at this point), I went to source tree, located the directory where everything was stored, added it to the repository, added a gitignore file and did everything else I was told to do in a brief tutorial I found(including linking sourcetree to this repository).

In the tutorial, and everywhere else, it says I need to click "git flow" to push these files to bitbucket. However when I try, I get an error saying that "The production branch you chose, "master", does not exist." And then it tells me it can't create this branch.

After looking at my repository I see that there is no "master" under the branches, however, in my bookmarks, it says that I am working under the "master" branch. Also, when I tried to create a "master" branch, it won't let me. Does anyone know how to get around this or solve this issue?

7 answers

Just had the same issue and this was top on google with no answer. You need to add something and commit it. Once you do that the master branch will be created in your local repo and you can then push and branch from it. 

Thanks... it did worked !! 

Same problem here :(

http://screencast.com/t/c1fDVIb3n

Any help?

Thank you.

We really need a way to automatically create a master branch using the Bitbucket web page.  As it is, it is impossible to create a new repo and integrate it with SAP Web IDE as it expects/needs a branch to do the first commit.

I can't write up instructions for my team to install git and use the command line just to do this one step.

You have to initialize your repository with your username and name, after that your master branch will be created and you will be able to commit your code.

git config --global user.email "your@email.com"
git config --global user.name "Your Name"

 

 

Yeah, that seems perfectly rational to continue to leave this out of the interface. 

so you cannot use the Bitbucket web interface to create this?  what sense does this make?  nor does it walk you through how to create it. 

Had the same issue after some merging mess.

Double-Click on Remotes-> origin -> master and check out the master branch again. For some reason, this hasn't been checked out (or was lost) out in my repo.

 

 

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

663 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot