Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,877
Community Members
 
Community Events
176
Community Groups

Need git gc on remote repository

Hello,

I have a private repository on an academic plan that has hit the 4GB size limit and I am unable to reduce the size with the options described at the suggested https://confluence.atlassian.com/x/xgMvEw link. I have tried enabling the Labs feature and reset with the force push (the latter of which has worked for me in the past, but did not work this time). The repository in question is bitbucket.org/nr*ec*/ec*nb**_*ar, please assist.

Thank you,

Lauren

2 answers

2 accepted

1 vote
Answer accepted
Ben Atlassian Team Feb 22, 2022

G'day!

I've successfully run garbage collection against your remote repository (nr*ec*/ec*nb**_*ar) in the back-end to clean up any dangling commits.
 
The repository size has reduced from 1.8GB and is now currently 139.2MB.
 
Would it be possible for you to check it on your end (by navigating to your Repository > Settings) and see if that has helped?
 
We want to inform you that we do have a Feature request: https://jira.atlassian.com/browse/BCLOUD-11593 to provide the option to run the GC from the end-user GUI. This way you need not raise a ticket and wait for the support person to run the GC on your behalf.
 
Our Dev team is currently working on implementing the feature request and we don't have any ETA for the fix. I would suggest you "Watch" this ticket for future updates from our Dev team.

Hope it helps.
Let me know how it goes.

- Ben (Bitbucket Cloud Support) 

1 vote
Answer accepted
Caroline R Atlassian Team Feb 22, 2022

Hi, Lauren, thank you for reaching out to Atlassian Community.

I ran the GC against your repository and managed to reduce its size to 259.9 MB.

I also would like to share with you that we have a feature request to allow users to mark repositories for git GC, as you can check here:

Please consider adding yourself as a watcher to receive the updates as we make progress with this. If you are not familiar with our Feature Request Policy, you can read more about it here.

Feel free to share any additional questions or concerns regarding this case.

Kind regards,
Caroline

Thank you very much Caroline! I had actually upvoted the request you mention some time ago and signed up to receive notifications on the issue because this affects a couple of our repos, it would be great if a manual git gc feature could be implemented!

Like Caroline R likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events