My Bitbucket repository doesn't show the "Overview" page option?

On many screenshots of bitbucket repositories online and in the Atlassian documentation I see a tab on the left menu "Overview" that takes the user to an Overview Page. This does not show up in any of my repositories and I'm wondering why?

6 answers

This widget could not be displayed.

@Ana Retamal Ortiz

I can confirm the problem. My friend wanted to exit repo used in our class, and he didn't have overview. I confirmed that I didn't have it either.

However, in other repo I always could see it. After I went there, and then back to the problematic repo, I could see Overview (but he still couldn't).

For him (and me before it fixing itself as described above) /repoowner/repo redirects to /repoowner/repo/src

I just confirmed repo owner also doesn't see the Overview, lol. And another normal user. And probably everyone else, but they are working on the project, so I haven't asked.

Hi @Ewa Zielińska! We recently added a change regarding the Overview menu in the UI, and maybe that's what you're experiencing as it's only been released for a limited number of users. However, anyone can opt-in or opt-out in the Bitbucket Labs section, you can reach it at https://bitbucket.org/account/user/<user>/features/ It's called 'New source browser experience' :

Screen Shot 2018-03-01 at 14.14.36.png

Let us know if you have any further questions!

Ana

Rebecca I'm New Here Mar 19, 2018

I found this bug too ! It's so wired than I tried almost every way I can imagine to fix this problem,all failed.I used different browsers and tried to create a new repository ,cannot solve my issue.

Hi @Rebecca, which bug are you referring to? Can you follow my explanation above and figure out if you're in old or new UI and then proceed to explain the issue you're facing?

Thanks,

Ana

Hi @Ana Retamal Ortiz,

I've registered a few minutes ago and created a new  repo z*****a.  There's no overview link in the sidebar.

I would like to init the repo with existing unversioned code.

Thanks,

Kornel

I have the new source browser experience feature turned on.

Ok, i turned off the feature and now I see the overview link.

Glad to hear that @Kornel Novak!

i just turned off the source browser lab feature and now i can see my repo overview link and with it, MY PUSH URL! which is kinda important i'd have thought. i couldn't find it anywhere apart from the overview page

I had the new source browser experience feature turned on and Overview option described in all your user guides was no where to be found. I turned off the new browser experience in the lab and the Overview option (and all the essential information it contains including the Push URL!) re-appeared.

Is the Push URL hidden somewhere in the new source browser UI that I could not find? 

Hi @Ana Retamal Ortiz, I just read all of the advises and answers you provided in this post because I have the same problem: I cannot find an overview page. First, I tried to access through different browsers, on incognito mode, etc. It was all unsuccessful. Then, when I tried to turn off the "New source browser experience" clicking on the link you posted I got this error:

image.png

What should I do now?

Thanks in advance.

Nevermind, I just fixed it. Thnx 4 nothing

HI Ricardo, I'm glad you figured it out. For anyone else with the same issue, you need to replace <user> in the URL I provided with your own username:

 https://bitbucket.org/account/user/<user>/features/

Hope that helps!

Ana

Hey @Ana Retamal Ortiz, this seems like an odd and counter-productive change. The Overview page is very helpful, I'm mostly managing developers so it's handy to see what's been happening, what's in the readme etc. etc.

This widget could not be displayed.

I wasn't seeing the Overview tab and read a few posts where Bitbucket support was pointing folks to https://bitbucket.org/account/user/(username)/features/ to adjust the setting for "New source browser experience"......this setting should be turned OFF, not ON. I don't think that was clear in the message. Turn it OFF and you will see the Overview tab. 

This widget could not be displayed.

Hi Kelzim! I've checked your account and I was able to see the "Overview" option. If you still can not see it, please send us a screenshot to make sure we're referring to the same thing. 

Cheers,

Ana 

Hello Ana,

I am currently teaching a class, and part of that class is learning about version control. I've asked students to create Bitbucket accounts for their work, and I have a few students who have reported the same issue as Kelzim -- No overview button/page.

I checked out one of the student's accounts with him, and I could find no options that may have been set inadvertently, but perhaps I'm just missing something. I even tried setting up a new test repo on this student's Bitbucket account, and sure enough, when the repo was created, there was no Overview button.

I'm attaching 3 screenshots... I apologize, I have to black-out the username, as this is a student account, but two of these shots both show a missing Overview button from the student's account. The third screenshot shows a picture of his repository that he shared with me (my username is jbachelorcsusm), and when logged into my account, I see the overview button, just like I do for all of my own repositories.

Do you have any idea what might be going on, and what I might tell students to do in order to rectify the issue? It's much more straightforward for them to share their repos with that nice, "Send Invitation" button one gets on the overview page of a repo, as opposed to drilling into repo settings, then into "User and group access".

Thanks so much for your help!

Jon

 

YesOverviewOnMyAccount.pngNoOverview2.pngNoOverview1.png

I am also still seeing this issue. Although, unlike Jon - NONE of our users are able to see the overview tab. The only reason I knew it existed is because I always see it on the documentation. Thanks!

 

jira-issue.png

This widget could not be displayed.

Hi @Jon Bachelor! What browser are they using? Can they reproduce this across different browsers and computers? Have they tried to access their accounts using the incognito mode?

I've searched for the name of the repo within the list of repos you have access to, but there are a few with the same name (I'm guessing each of them from a different student). Since you'd like to keep them anonymous, would it be possible that you give me a hint just so I can find the affected users? You could just show me the first and last letter, something like 'u******e'. If you're still not comfortable with that, let me know and I'll create a Support ticket for you.

Cheers,

Ana

Thanks so much for your super fast reply, Ana!

Let me start by asking students to try a different browser, and if that shows similar results, I'll ask them to try incognito mode as well.

If unsuccessful, I'll ask them if they are ok with me providing a username hint for you to be able to check out their account.  =)

Thanks for your help!

Jon

This widget could not be displayed.


@Kelly ZImmermann, the screenshot you posted is from BB Server 4.9.1 where there's no overview. Hope that explains!

Let us know if you have any questions!

Ana

This widget could not be displayed.

Hola Ana,

 

Tengo exactamente el mismo problema.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 10, 2018 in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

243 views 14 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you