Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,655
Community Members
 
Community Events
165
Community Groups

Multiple missing repositories

Edited

Multiple repositories are missing from my account, and I cannot find any evidence to explain why.

The first missing repo was at: <repo_url_removed> where I published source code relating to my blog. Now it just returns a 404 error.

The most recent email notification I received relating to this repo was 12 May 2020, so it was clearly present/active a little over a year ago. There have also been approx 6 forks of this repo made in the past, and none of them exist now either.

I checked the audit log for my workspace and the last action was on 2018-06-29 which corresponds plausibly with the last time I logged in. There are events showing the creation of several other repos (eg pimpvscom and two other private repos) and no other activity, certainly no deletions. One screen actually says I have 9 repos in my workspace, but I can only see and access 2.

Since the repo was demonstrably active on a date after my last login, I cannot have deleted it myself. It appears to have disappeared in some system failure.

I have searched all my email and there is no notification of any deletion or any reason to think a repo might have been deleted. This seriously undermines my confidence in the reliability of this service.

Please Atlassian, where is my data?

3 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

2 votes
Answer accepted

Hi @gavinb,

I checked the workspace associated with your Bitbucket Cloud account and it owns several Mercurial repositories. Are the Mercurial repos the ones you are missing?

We sunset support for Mercurial repositories last year, we sent an email to admins of Mercurial repos and also announced it publicly here:

As of 26th August 2020 all Mercurial repos have been disabled and cannot be accessed.

If you'd like a copy of these repos, please feel free to let me know. I can create a support ticket for you, so that we provide you with a copy of these Mercurial repos.

Kind regards,
Theodora

Hello Theodora,

Yes they were Mercurial repositories. I found the announcement email so I guess I must have missed acting on it at the time, though it was only a single generic message and made no mention of the actual repos affected. No reminder or followup either, which is a shame considering the significance of the change. Anyway, that boat has sailed.

So yes, if you would kindly furnish a copy of the archived repos just to make sure I have everything in sync that would be great. Thanks!

Regards -

  :: Gavin

Hi Gavin,

Of course, I went ahead and created a support ticket for you using the email of your community account. You should have received an email with a link to the support ticket. If you haven't, please feel free to let me know and I can post the ticket URL here (the ticket will be visible only to you and Atlassian staff, no one else can view its content even if they have the URL).

One of our engineers will respond to the ticket and provide you with a copy of the Mercurial repos owned by your Bitbucket workspace. Please feel free to let me know if you need anything further!

Kind regards,
Theodora

Thanks, Theodora.

I received the instructions on downloading the bundle from Alan in support. After extracting the folder tree, I went to clone the repos. Two of them failed with an error:

abort: preoutgoing.bb_perm hook is invalid: import of "libbucket.hooks" failed

I searched and didn't find much useful. I compared the .hg/hgrc files of the two that failed with the others that worked. This specific hook seemed to be the difference. So I commented it out and tried again, and then the clone worked. Including these details in case anyone else encounters the same problem.

I am now able to access all the repos, including some data that was missing. So I am very grateful for this restoration! Best regards,

Like rjt69 likes this

@Theodora Boudale 

I too would love to get my mercurial repositories.   I tried creating a ticket, but it pointed me to documentation.  Would you please create a ticket for me so that i can get my private mercurial repositories back?  Please.  

<workspace_url_removed>

<workspace_url_removed>

 

@Theodora Boudale 

To be clear, i cannot find my mercurial repositories.  Had used them extensively pre-covid.  Trying to resuscitate a few processes here, but it a majority of it points back to these mercurial repos under rjt69 and eceo.  I ended up making this GDPR request because it seemed to be the only one i could successfully create.  Please see if that will work. 

https://getsupport.atlassian.com/servicedesk/customer/portal/44/DATA-13986

@Theodora Boudale 

Hi, can I get my Mercurial repos too? As far as I remember I didn't get the notice email. This is very unfortunate, when you want to back up your code, but the back up server delete your data without chance for me to backing them up. Thanks.

 

Here's my workspace URL:
<workspace_url_removed>

Hi @febrinaldi,

I'm afraid that the Bitbucket Cloud Support team is no longer able to restore those repositories.

If you are looking for a Mercurial repository that was public, all the public repos were archived by Software Heritage:

https://bitbucket-archive.softwareheritage.org/

We will not be able to meet any further requests for recovery of private HG repositories.

Kind regards,
Theodora

Hi everyone,

Atlassian made a decision to move away from maintaining and supporting Mercurial repositories in 2019.

This was announced in community:

and on our blog:

Bitbucket Cloud Support team is no longer able to restore those repositories.

If you are looking for a Mercurial repository that was public, all the public repos were archived by Software Heritage:

We will not be able to meet any further requests for recovery of private HG repositories and users will need to recover those from local copies only.

Kind regards,
Theodora

+1 because I've lost AFAIK one repo on my account as well. It disappeared mysteriously two days ago without a trace anywhere. 

This is bad!

Hi @ayazahmedkhan,

If you could access the repo until two days ago, then your issue is related to something other than the Mercurial repo deprecation. My first guess would be that the repo may have been deleted or transferred to another workspace by another admin, but we'd need to check.

Please create a new question in community (while logged in to the account that has admin access to the workspace that owned this repo) and we can look into your specific issue.

Kind regards,
Theodora

TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,245 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you