Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Merge Button is disabled(grayed out) even there is no conflicts.

Hi .,

From today morning We are facing issue Merge Button is disabled(grayed out) even there is no conflicts in pull requests.

Please help me out in resolving this Issue.  we are facing issue in merging the pull request because of this.

Screenshot 2020-11-23 at 9.46.31 AM.png

4 answers

2 accepted

1 vote
Answer accepted

We found a quick fix for this by disabling new pull requests experiences in https://bitbucket.org/account/settings/features/

Great!.. Thanks

@shawnleggeIts already disabled in my account. also tried enable and disable new pull requests experiences but didn't work for me. still same issue.

You need to enable the "New pull request experience" in https://bitbucket.org/account/settings/features/ and make sure the merge strategies in your repo settings is "Fast Forward". After that you will be able to merge the PRScreen Shot 2020-11-23 at 5.00.21 pm.pngScreen Shot 2020-11-23 at 5.06.12 pm.png

thanks ! its works

0 votes
Answer accepted
Jimmy Seddon Community Leader Nov 22, 2020

Hi @deepan,

If you hover over the merge button, does it give you any information about why it is grayed out?  The most common items other than conflicts that will prevent this are branch permissions or merge checks (which are only relevant to premium subscriptions).

I hope that helps!

-Jimmy

I have the same issue. Nothing appears when you mouse over the button.

 

Edit: Using Firefox 83.0 (64-bit) on Ubuntu 16.04.

Like shawnlegge likes this

Hi @Jimmy Seddon 

Nothing appears when you mouse over the button. no information or error.

i just want to clarify there is no merge conflicts or branch permission issue at all.

all pr's has same issues.

Jimmy Seddon Community Leader Nov 22, 2020

@deepan I just created a test PR in a free instance I own, and it looks like I can see the same thing but only when using the "Old Pull Request Experience".  I think what you are running into is this: https://jira.atlassian.com/browse/BCLOUD-20079

The workaround is to turn on the "New Pull Request Experience" in the Labs section of your account, which you should be able to access from here: https://bitbucket.org/account/settings/features/

I hope that helps!

-Jimmy

@Jimmy SeddonThis worked for me. Thanks for your help

Jimmy Seddon Community Leader Nov 23, 2020

@deepan @waleems @Pak Woon @shawnlegge I would encourage each of you to go and vote/comment on this bug: https://jira.atlassian.com/browse/BCLOUD-20079

Having more customers indicate it affects them my help get Atlassian to fix the bug sooner.

-Jimmy

We are having a similar issue

@shawnleggeThanks for put it here.

We are facing the same issue, we had never faced this issue before. Would glad if someone solved this...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,920 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you