Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Markdown formatting broken in project overview

Alexis Dray June 20, 2018

bitbucket cloud: our markdown in README.md is broken / does not render as markdown when we first land on the repository overview page in the web UI.

 

Within the project, if we click somewhere else, like settings, and then back to source, the README markdown then renders as expected. 

 

does anyone know how to fix this behaviour? 

 

Screen Shot 2018-06-20 at 2.59.29 PM.jpgScreen Shot 2018-06-20 at 2.59.19 PM.jpg

25 answers

31 votes
mikaspell March 2, 2019

It took a lot of time and so nothing is done... This task is NOT SOLVED!

Tom Cervenka September 17, 2019

People, please start voting up these posts. Maybe that will get their attention.

Shumnan Suengjitsiriroj September 19, 2019

Yes, me too !

Bruno Justo August 19, 2020

The solution I found is to separate the list items with a blank line. For example:

- item 1

 

- item 2

 

- item 3

 

This also works for enumerated lists.

I know it is not the right way, but until they fix the problem, it is the only solution I have found.

17 votes
Gabriele Ciappelloni July 11, 2018

Hi there,

i had the same issue, i solved this disabling the "New source browser experience" feature in Labs into my profile.

Hope this helps!

Gab

pabuisson July 11, 2018

Thank you so much Gabriele! Indeed, I tried to disable the "New source browser experience" and the README is displayed as expected again.

Thanks a lot for your help :)

Like Ali Albousaifi likes this
Torben Hein September 14, 2018

Thanks a lot

This helped me massive - I never noticed that the rendering broke with this lab and did not drew the connection.

Deactivated - runs as expected again

 

Yay!

Giovanni Lorenzini February 16, 2019

Thanks a lot for your help ;-)

OmarX June 6, 2019

the feature itself is removed from the lab options , so this not working anymore:(

Like # people like this
9 votes
Matvey Levinson May 10, 2019

Disabling "New source browser experience" does not help

Andraž Kos (@gmail) May 19, 2019

+1

The existing fix was patched, now it is broken everywhere.

Like # people like this
8 votes
The-Dung Nguyen February 26, 2019

I noticed that problem for months ago but was not bothered until I have to show new team member our markdown documentation. As of February 2019, still not fixed.

7 votes
Keith Brown July 16, 2020

I just hit the same problem in July 2020.  Something so simple should definitely work right out of the box.

3 votes
Gabriele Ciappelloni May 20, 2019

the problem still exists and the suggested setting does not help anymore...

Really boring and weird.

Andraž Kos (@gmail) May 20, 2019

I've traced it to happening when you try to make numbered list, but use multiline with offset:

1. one

  one b

  one c

2. two

two b

two c

 Result is

1. one

one b

one c

1. two

two b

two c

Like anna.sikorka likes this
3 votes
pabuisson July 2, 2018

Exact same problem for me, it's been quite a while. It did not bother me so much at first, but for an open source project, the README is pretty essential and having it displayed as a blob of text just makes it useless. It'd be great to know what's happening.Capture d’écran 2018-07-02 à 23.08.40.png

Could you find any more information about this @Alexis Dray?

Alexis Dray July 2, 2018

unfortunately no movement on this issue for me 

pabuisson July 3, 2018

It's a shame... I hope more users will comment on this issue so that it stays on top and visible and would be dealt with by Bitbucket, it's really annoying. No use writing a README file if it's not displayed correctly 😕

Like Tom Cervenka likes this
alexis-magina August 23, 2018

Yes, same problem for me. I deactivated the "New source browser experience feature" for now. Pretty useless if the readme only works 10% of the time.

Hope Bitbucket team will fix that soon.

Deleted user September 26, 2018

Also deactivated the “New source browser experience” feature and it works. I hope the Bitbucket team will fix this issue soon.

Rob Hasker November 13, 2018

Not responding on such a simple feature makes me question how long Bitbucket is for this world. Seeing as how they don't seem to be fixing this bug, can someone give a more detailed description of how to turn off the feature? I can't find it in any of the project-specific or account-specific settings, but maybe I missed it.

alexis-magina November 13, 2018

Hi Rob,

You can turn it off by : clicking on your profile avatar (right/bottom screen), and select "Bitbucket Labs". (or URL should be something like that : https://bitbucket.org/account/user/YOUR-USERNAME/features/

Then turn off the "New source browser experience" functionnality.

Like Rob Hasker likes this
Rob Hasker November 13, 2018

Thanks, though for me the profile avatar is at the bottom left of the screen (in case someone else is not sure what's meant).

shansurat May 22, 2019

This fix is not working anymore.

Like # people like this
Gabriele Ciappelloni May 22, 2019

Yep, unfortunately not... :(

2 votes
Rizal Gowandy November 24, 2019

Welp, still broken almost a year now.

Considering moving the whole project out of Atlassian XD

2 votes
OmarX June 3, 2019

its broken in some projects and some not, its broken on Chrome, but works on Opera browser, its really confusing!

plz fix this.

1 vote
mcompte September 22, 2021

I can't believe that more than 3 years later this is still not fixed.

My markdown rendered fine just minutes ago, now it is not. I can render it fine in my computer and on GitHub.

So, I guess we only have one way out, moving all our repositories out to another provider.

1 vote
Исмаил_Валиев March 15, 2020

Same to me.

Tried to use some workarounds, but no luck. 

I experience incorrect code blocks display inside list items. For some reason Bitbucket displays them as inline code. "Root level" code blocks works well.

1 vote
Janno Schouwenburg December 16, 2019

Same here.

1 vote
Werner November 18, 2019

Hi,

After so long... still not working.

Bitbucket Cloud, no 'new source browser experience' on Labs config, and Markdonw in README.md or other's is not displayed correctly :(

Any ETA  Atlassian on taking a look at this? 

1 vote
Gabriele Ciappelloni September 17, 2019

Hi there,

now seems that this issue disappears...

I didn't change anything inside my README files or account settings...

 

Gab

Sergey Potapov September 17, 2019

+1
Works correctly for me now

Danielle Toutoungi October 8, 2019

I am still having this issue and cannot see an option to disable "new source browser experience". 

1 vote
Jehannes Stellingwerf September 2, 2019

Ran into this issue too

Tom Cervenka September 17, 2019

Me too.

1 vote
stefan August 22, 2019

Until Atlassian takes a look into this I put a note to all READMEs about the issue pointing to this thread. Some customer teams already asked to move their repos to some alternative solution as they are not able to read a simple README...

Maybe Atlassian will introduce QA if they see us fading away.

Tom Cervenka September 17, 2019

Good idea. I can't believe they haven't fixed this by now.

Like Shumnan Suengjitsiriroj likes this
1 vote
Jarad Duersch August 20, 2019

Is there a bug reported on this and what is the number? I can't find it

1 vote
Morgan Mackay-Payne June 16, 2019

For me at least, the option to disable the "broken new source browser experience" seems to have been removed.

Morgan Mackay-Payne June 17, 2019

What a joke. How does shit like this pass QA?

Like Joris Vleminckx likes this
1 vote
David Heidrich June 4, 2019

This is so frustrating. Atlassian, please fix this bug. It's impossible to share readme files with colleagues, people have to view them in a markdown editor.

1 vote
Rob Hasker December 29, 2018

I'm reasonably sure the problem we were seeing was not a cache issue. It's possible there's been a fix, but we were seeing the incorrect behavior on multiple platforms.

1 vote
andersonlorena December 29, 2018

I had the same issue, solved when I pressed CTRL + SHIFT + F5 (Full page refresh)

Probably there is something wrong with state or cache.

0 votes
Armita Safa January 20, 2023

I experienced this issue as well. After trying different things, I figured out that if I add extra blank lines above and below the tables and between the listed items, it renders properly.

0 votes
Fadli Hidayatullah July 3, 2022

I solved it by editing the Readme file through Bitbucket

Deleted user July 3, 2022

Yes, great!

But it’s a temporary solution and you have to commit your changes and pull them afterwards to your computer. Whenever you change the file locally and push it to Bitbucket, you have the same problem back.

0 votes
Yanice Agoune April 27, 2019

This worked for me as well. Thanks!

Rodrigo Otávio Moraes May 3, 2019

Hi, please indicate-me where is 'New source browser experience' config on the labs?

Gabriele Ciappelloni May 3, 2019

Please see the Alexis De Moor answer, a few lines above.

Gab

Like Yanice Agoune likes this
0 votes
Chris Witte April 4, 2019

I've just experienced the issue as well.  The workaround to disable "new source browser" experience worked for me.  Still broken 9 months after the original report.

Tom Cervenka September 17, 2019

You mean it "didn't" work for you, right? I can't even find that setting!

Like mcompte likes this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events