Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Link Jira and Bitbucket

Hi all

I try to link Bitbucket Server and Jira Server (Link with Confluence and Bamboo worked)

What im doing.

  • I go to Bitbucket Admin Menu and try to link my Jira 
  • Redirect to Jira and there i get an error

Log on Bitbucket:

2021-04-27 08:20:32,811 WARN [AtlassianEvent::thread-6] ytremp @1H6OL6Mx500x36x0 hwz3xf 195.138.215.183,10.35.35.2 "GET /rest/applinks/3.0/applicationlinkForm/manifest.json HTTP/1.1" c.a.a.i.c.DefaultRemoteCapabilitiesService Exceptio
n trying to get Applink for manifest with ID 7c7383dc-9980-3de4-a9d8-9f6c19ebc8ad

Log on Jira

2021-04-27 08:20:41,055+0200 https-jsse-nio-8080-exec-694 ERROR ytremp 500x30873x3 dd8627 195.138.215.183,10.35.35.2 /rest/applinks/3.0/applicationlinkForm/manifest.json [c.a.a.c.rest.ui.CreateApplicationLinkUIResource] ManifestNotFoun
dException thrown while retrieving manifest
com.atlassian.applinks.spi.manifest.ManifestNotFoundException: com.atlassian.applinks.internal.common.net.ResponseContentException
at com.atlassian.applinks.core.manifest.AppLinksManifestDownloader.doDownload(AppLinksManifestDownloader.java:207)
at com.atlassian.applinks.core.manifest.AppLinksManifestDownloader.access$000(AppLinksManifestDownloader.java:52)

....

2021-04-27 08:20:41,060+0200 https-jsse-nio-8080-exec-694 ERROR ytremp 500x30873x3 dd8627 195.138.215.183,10.35.35.2 /rest/applinks/3.0/applicationlinkForm/manifest.json [c.a.a.c.rest.ui.CreateApplicationLinkUIResource] Null manifest r
etrieved
2021-04-27 08:20:41,057+0200 https-jsse-nio-8080-exec-766 WARN ytremp 500x30872x2 dd8627 195.138.215.183,10.35.35.2 /rest/applinks/3.0/status/7cf449e4-de7e-3ee4-87f0-059503fb8262 [c.a.a.i.migration.remote.TryWithCredentials] You do not
have an authorized access token for the remote resource.

bitbucket1.JPG

After click "Fortfahren" in Jira, it loads endless. I cancel it, and see the following in Jira:

bitbucket2.JPG

In Bitbucket Status is green:

bitbucket3.JPG

If I know want to set (on Jira) the connection entry to OAuth, it shows an error, that bitbucket is not reachable.

On Jira I also can click authenicate to see Status (Authentifizieren Sie sich, um den Status zu sehen) and then I get the following error.

bitbucket4.JPG

I still think the error is on Bitbucket, because all other applications worked (Jira, Confluence and Bamboo).

 

Many thanks!

1 answer

Hi @Yves Tremp Can you check Bitbucket server is reachable to Jira server on port 443 and same Jira is reachable from Bitbucket server using telnet command?

From Jira Server :

telnet bitucket-server-ip 443

From Bitbucket :

telnet jira-server-ip 443

For application links to create between atlassian apps application should be reachable on port 443

If they are reachable then check the ssl certs used on both the applications are imported to each others Java keystore.

Please find the below document to check if you running with same issue:

https://confluence.atlassian.com/kb/application-link-not-working-due-to-manifestnotfoundexception-393904879.html

Let me know how it goes.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

389 views 9 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you