Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issues grabbing source from Bitbucket within AWS CodePipeline

Edited

When trying to Release a change from AWS CodePipeline (we have an existing Bitbucket integration), we intermittently get the following error message below.

"Action execution failed

[Bitbucket] Bitbucket returned an Internal Error exception. Please retry shortly. If the issue continues it may be reported on the Bitbucket status page at https://bitbucket.status.atlassian.com/"
Usually retrying it gets past this issue and continues normally, but starting this afternoon around 1:30PM CST, we've been consistently receiving this message, even with multiple retries and on all of our other pipelines. We're not seeing an outage reported on https://bitbucket.status.atlassian.com/
Here's the image pop-up we get for Action execution failed when we try to deploy our changes:

Screen Shot 2022-01-12 at 2.14.34 PM.png

11 answers

1 accepted

4 votes
Answer accepted
Mark C Atlassian Team Jan 12, 2022

Hi Everyone,

We received an update from our engineering team that the issue which is affecting the AWS CodePipeline integration feature is now resolved.

You can further check this incident here: https://bitbucket.status.atlassian.com/incidents/bckkpd21xrgg

We apologize for the inconvenience this has caused you and your team.
If you need more help, please do let us know.

Regards,
Mark C

It is happening again now. Haven't been able to pull from Bitbucket for some time now.

Like Andrew likes this

I can verify that when I change the repository settings to "Full Clone" it starts working again.

Same, happening again!

Like Andrew likes this

Hi @Mark C , seeing the same issue on my end. I just setup a CodePipeline with BitBucket source. The Source stage worked fine on first launch right after creating pipeline. Once I committed a new change in BitBucket, Source stage reran and failed. Reverted to original source code and same issue. I think its related to the webhook and will troubleshoot that next. Just want to confirm issue is still present.

 

Edit 1:

There's a few url redirects I've noticed when accessing target repo from project level in bitbucket webapp. It adds a redundant '/src/main/' to path. Not sure if this is new or has always existed but doesn't seem right.

Also, when I access the repo publicly with the https clone address provided, there's a pop up about credentials no longer needed (click OK) and lands me on what should be the repo address BUT without the redundant '/src/main/'. Reloading this page presents same error but once I add a '/' to end of url, shazam. It redirects through the redundant URL and correctly displays the repo.

Hope this helps. Hoping a fix is coming soon.

2 votes

Same issue for me

2 votes

Had the same issue since Jan 12, 2022 6:00 PM (UTC±0:00)

Have the same issue, which started a few hours ago. Full clone is not an acceptable workaround for me (using some codepipeline feature which does not work with full clone)

1 vote

I was able to resolve this by ensuring the code pipeline source stage does a FullClone rather than the default "CodePipeline default"

Thanks, this fix the issue !

Having the same issue

I don't know if this will help the attlassian devs to debug this issue but codepipeline is using this URL to get the src for the branch https://bitbucket.org/org/repo/src/branch-name and that results into "

"Resource not found

if you have your branch naming convention as feature/branch then bitbucket fails to redirect to URL like so 

https://bitbucket.org/org/repo/src/3e823120cc75e4340c6b8c78e08c1e51484/?at=feature/my-branch-name

Hi, how do you know that? tks

Like Arturo Hurtado Romero likes this
0 votes

Same issue here!!!

0 votes

As of 16 January 2022, this bug still occur. Thanks to Frank DiRocco's advice, I solved it by setting code_build_clone_output as True in my CodeStar Connection.

Like this:

aws_codepipeline_actions.CodeStarConnectionsSourceAction(
action_name='BitBucketSource',
owner="owner",
repo="repo",
connection_arn="arn",
code_build_clone_output=True, # Bitbucket fix
output=source_code
)

We experience this issue today for all our branches with aws pipeline

Problem solve! nice!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

185 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you