Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issue while cloning and downloading Bitbucket repo

Edited
Checking out files: 100% (8437/8437), done.

Downloading apacheFiles/html/css/background.jpg (23 KB)

Error downloading object: apacheFiles/html/css/background.jpg (332eb41): Smudge error: Error downloading apacheFiles/html/css/background.jpg (332eb41d6b1
50f4936e43303faea034096fcb08f3f26f99f320432e66a3ffccf): batch response: Post https://eu-muc-git01.ux.dsone.3ds.com/scm/~gai2/squishtests_teamtau.git/info
/lfs/objects/batch: x509: certificate signed by unknown authority                                                                                       Errors logged to D:\squisher\squish\SQUISH_TESTS_RELEASE_2019x\.git\lfs\logs\20190103T131534.664894.log                                                  
Use `git lfs logs last` to view the log.

error: external filter 'git-lfs filter-process' failed

fatal: apacheFiles/html/css/background.jpg: smudge filter lfs failed

warning: Clone succeeded, but checkout failed.                                                                   
You can inspect what was checked out with 'git status' and retry the checkout with 'git checkout -f HEAD'

 

3 answers

Hello @edwin

 

I tried using both commands but still it is displaying the same message.

Any other way??

Thanks in advance!

 

Regards,

Suhas BHUJBAL

1 vote
edwin Community Leader Jan 03, 2019

Hi @SUHAS BHUJBAL,

The error is with a certificate

/lfs/objects/batch: x509: certificate signed by unknown authority

You can try the clone using

GIT_SSL_NO_VERIFY=1 git clone ...

 or

git config http.sslverify false
git clone ...

git config http.sslverify false

 

Worked for me in Git LFS repo that was having problems, was able to successfully push after that without getting the X.509 certificate error.

@edwin 

I have the same problem with my repository. There is one file the is signed by an unknown authority. 

Turning off SSL verification did not work. And i do not like turning off SSL verification as a solution anyhow. that means that every developer using this repository has to do that or the problem occurs. 

Is there a way to find out that authority signed the certificate and add that to the list of known authorities?

@Avner Callender Did you manage to solve this issue?  I'm experiencing the same when trying to clone into a Docker image.  The weird thing is that it was working until a few days ago and all of a sudden started breaking.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,736 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you