Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,673
Community Members
 
Community Events
176
Community Groups

Is there a way to invoke Pull request rescoping for my Cloud Bitbucket repository?

I experienced some issues with the scope of created Pull requests on at least two of our repositories. I was trying to find some solution and found this 
https://confluence.atlassian.com/bitbucketserverkb/how-to-diagnose-debug-issues-with-pull-request-rescoping-in-bitbucket-data-center-1026057670.html
The issue described here is pretty similar to mine so I think this is it but it is not for Cloud BitBucket.

How to invoke rescoping the pull request for my specific repository?

Or just how to solve the issue with the scope of my pull requests?

 

1 answer

0 votes
Patrik S Atlassian Team Mar 23, 2022

Hello @Marek ,

Thank you for reaching out to Atlassian Community.

I'm afraid we don't have a direct equivalent API call in Bitbucket Cloud to trigger a pull request rescoping, but I think you can do it indirectly by pushing a new commit to the repository, which will make the pull requests to be updated.

That said, I'd like to understand more about the issue you are trying to solve here, so would you give us more details on the reason you were looking to manually trigger a rescoping of a pull request ? Is the issue you are facing related to recent commits sometimes not showing in the Pull Request ?

Looking forward to hearing from you.

Thanks, @Marek .

Kind regards,

Patrik S

Hello @Patrik S ,

More details: 
I've merged my branch to master using the squash option (by mistake actually, and I didn't delete my branch) and then added a few more commits on top of my branch. And next pull request created from my branch to master had all previous and new changes.

Recently I saw another issue (I was not involved in comments) also after merging by squash but in the next pull request (probably) from a different branch than the previous one, there were no changes at all. The list of commits in scope was correct but the list of changes was empty.

I've tried to create a new branch on top of a feature branch and then create a pull request from it but the scope was still not correct.

We've done a review locally.

Next time I will try to reset my changes with force push and then again push it to the BitBucket - I would like to avoid adding some commits on top just to invoke the refresh of branch state in the cloud repository.

Maybe this info help you solve the issue on the backend side ;)

Best regards

Marek

Patrik S Atlassian Team Mar 25, 2022

Hello @Marek ,

Thank you for providing additional context.

Since I was not able to simulate this behaviour on my side, and from your description I assume it not happens all the times, checking our internal tools I've noticed you have access to a premium subscription, so if this behaviour happens to occur again, I would kindly ask you to open a ticket for our support team (getsupport.atlassian.com), so our support engineers will be able to access the Pull Request and respective branches and better investigate what might have happened, and open a bug in case identified it was a not an expected behavior.

Thank you, Marek :)

Kind regards,

Patrik S

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events