Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Is my cloning stuck or is it just taking a long time? Edited

I'm very new to git and I've been cloning a repo from BitBucket cloud in SourceTree to my local machine for roughly an hour now. My internet connection is average and so I'd usually chalk this up to a large repo (I don't have access to check the repo size in BitBucket but I'm cloning an organization's entire website, so I assume it's quite large).

However, the loading bar for the cloning process is full, yet the the output is stuck on "cloning into '<path to repo>'. . ."

Apparently there's no way to accurately check the progress of a clone, but this seems like an abnormally long time. Does this sound like the cloning is stuck or has encountered an error somewhere?

 

EDIT: Spelling

4 answers

1 accepted

1 vote
Answer accepted

Apparently it was an issue with SSH. After about 2.5 hours the clone failed and I tried again using HTTPS. It worked fine.

Hi Luca,
Same issue here. Could you fix it later?

Hello Ahmedur,

As I mentioned above, all I had to do was use HTTPS and the clone was successful.

Unfortunately I don't remember any more of the details of this issue.

Best of luck!

Like masteryder likes this

hi Luca, how did you choose between HTTP and HTTPS? 

i think when you set up your profile

Like kooliatef likes this

I tried both SSH and HTTPS, and they both seemed to take an eternity. Then I tried cloning with Git Bash (a text-command tool), and it showed progress was slow but steady.

The problem is that SourceTree's progress bar is completely useless, since it doesn't actually show progress. Additionally, the "Show full output" checkbox also does not show full output. So it's impossible to know if anything is happening. I found that using a command-line tool gives you a lot more information than SourceTree's GUI:

 

Screenshot2.jpg

this. also, i'm using bitbucket so i don't know if that's related, but the fact that it works nicely from the terminal indicates a bug on the sourcetree side

I could clone from URL in sourcetree successfully for a smaller git repo but when I tried same for a big repo then it got stuck forever.

Like # people like this

This definitely seems to be a problem with Bitbucket's SSH implementation.  I have been able to make SSH connections and do clones of Github repositories using SSH URLs.  As soon as I did a clone of the HTTPS variant, the BitBucket variant worked.  100% this is something broken with Bitbucket.  Now with Gitlab or Github offering private repos, it may not be work keeping code in Bitbucket with fundamental problems like this.

I had to use Tortoise Git to see the progress in byte transfer to know whether actually something is happening when cloning.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,826 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you