Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Invalid Credential errors on SourceTree

I could not commit any files through SourceTree today. I always got "Invalid Credential" errors whenever I tried to pull or push or do anything on SourceTree. I tried these methods to fix but no luck:

1. Remove password file from \AppData\Local\Atlassian\SourceTree and do restart-fetch-input password, but still have "Invalid Credential" errors;

2. Update my Bitbucket password and retry on SourceTree but still have "Invalid Credential" errors.

Please help me as soon as possible!

1 answer

1 vote
Patrik S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 17, 2023

Hello @Helen Xu and welcome to the Community!

From the description of the issue I suspect you are using your account password to authenticate on Sourcetree, and this is likely what is causing the invalid credentials error.

When using basic authentication on Sourcetree (and any other git activity over HTTPS), you need to provide the following as your credentials : 

  • Username : your bitbucket account username (not your email address). You can check the username under your bitbucket account settings.


  • App Password: a "token" that will be used for authentication (it's not the account password you use to log in to the UI). If you haven't already, you can create a new app password

You can try creating and using an AppPassword in your Sourcetree configuration and let us know how it goes.

Thank you, @Helen Xu !

Patrik S

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events