Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Importing Bitbucket Cloud project to Bitbucket Server fails

I'm trying to import repositories from Bitbucket Cloud to my Bitbucket server v5.11.1.


My server is running behind reverse proxy and is configured to use SCL git version 2.9.3 (https://www.softwarecollections.org/en/scls/rhscl/rh-git29/).

When i'm trying to import repository from Cloud i'm getting this error in atlassian-bitbucket.log file.

2018-07-11 14:58:54,260 ERROR [pool-9-thread-2] c.a.b.i.i.repository.RefSyncTask Failed to import repository: IMPORT/project[243]
com.atlassian.bitbucket.scm.CommandFailedException: '/opt/rh/rh-git29/root/bin/git -c gc.auto=0 -c credential.username=MyBitbucketUser-c credential.helper= fetch --force --prune --progress https://MyBitbucketUser@bitbucket.org/MyBitbucketUser/project.git +refs/*:refs/*' exited with code 141 saying: git-remote-https: error while loading shared libraries: libcurl-httpd24.so.4: cannot open shared object file: No such file or directory

3 answers

It looks like SCL git version didn't want to work with my bitbucket server even thought  all libraries where installed. So my solution to this problem, downloaded latest git version from Github and compiled it from source then added neccesary paths. Now everything works. :)

Awesome news @TWN_karlhendrik! Thanks for sharing!

0 votes

Hi @TWN_karlhendrik,

Based on the log, it looks like there may be a missing library on the Server hosting Bitbucket.

I found this article that may help addressing this problem.

 

As alternative, you could also attempt to import the repository using the Import an existing Git project into Bitbucket Server on the following page:

Importing code from an existing project

 

Cheers,

Caterina - Atlassian

Hey @Caterina Curti,

 

At first i thought also it might be missing library. I tried solving my problem based on this article, but i didn't help. Because when i run following command:

find / -name libcurl.so.4, then it outputs the library path.

/usr/lib/libcurl.so.4
/usr/lib64/libcurl.so.4

Regards,
Karl Hendrik

That's interesting and I've seen similar cases in the past, but there does not seem to be a straightforward (and one fit all) solution for this.

 

What about using the Import code from an existing project option instead?

I'm currently trying out option, my only problem with that is, i have 100+ repos and i'm want to import all of the repositories to my Bitbucket server. :(

If anyone else runs across this same error I was able to get past it by linking the scl libcurl-httpd24.so.4 from it's location to /usr/lib64.

ln -s /opt/rh/httpd24/root/usr/lib64/libcurl-httpd24.so.4 /usr/lib64/libcurl-httpd24.so.4

 The answer from the BitbucketKB didn't work for me on Bitbucket 6.2.1.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

2,154 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you