It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I musst write all time :7990 in my URL to BitBucket-Server

I have setup BitBucket and have change the Apache2 - Setting for the Subdomain "bitbucket.domain.eu" like this:

 

<VirtualHost *>
ServerAdmin admin@bitbucket.domain.eu
ServerName bitbucket.domain.eu

ErrorLog /error.log
CustomLog /access.log combined

ProxyRequests Off

<Proxy *>
Require all granted
</Proxy>

ProxyPass / http://localhost:7990/
ProxyPassReverse / http://localhost:7990/
</VirtualHost>

 

But I can't reach the BitBucket-Server. I must put the Port 7990 after the URL like this:

 

bitbucket.domain.eu:7990

 

to reach the Server.

 

I have the same Apache2 config for the Jira-Server and it's running fine... But Bitbucket-Server is not running fine.

 

What can I change ncoh to make it work properly?

 

THX for answer... 

2 answers

0 votes

Add the port to your <Virtual Host:*7990>

Also like this:

 

<VirtualHost *7990>
ServerAdmin admin@bitbucket.domain.eu
ServerName bitbucket.domain.eu

ErrorLog /error.log
CustomLog /access.log combined

ProxyRequests Off

<Proxy *>
Require all granted
</Proxy>

ProxyPass / http://localhost:7990/
ProxyPassReverse / http://localhost:7990/
</VirtualHost>

 

 

?

I hvae test it... but it does not work...

Oh... I have forget it... I will test it now with :

Also with the :7990 it will not open the BitBucket-Server

 

Now the Apache2 Conifg-File is like this:

 

<VirtualHost *:7990>
ServerAdmin admin@bitbucket.domain.eu
ServerName bitbucket.domain.eu

ErrorLog /error.log
CustomLog /access.log combined

ProxyRequests Off

<Proxy *>
Require all granted
</Proxy>

ProxyPass / http://localhost:7990/
ProxyPassReverse / http://localhost:7990/
</VirtualHost>

 

 

But I must put the :7990 after the URL bitbucket.domain.eu to reach the Bitbucket - Server... 

sorry for the delay, what does it say in the error.log when you try just the url? Is this installed on windows or linux? Is your apache o the same server?

Also, check the /etc/hosts file.

in the morning, I will look at how we have our virtual hosts set up. We use a proxy to navigate traffic to all our tools - Jira, Confluence, Bitbucket, and Bamboo.

There is no error in the Log... All fine.

Can you tell me the configure of the Proxy? I use also the Proxy-Settings in Apache2. Is this the same?

Sorry for the delay, our proxy isn't much different except that we have a few rewrite rules. Can you take a look at your server.xml in the bibucket home -> shared directory. Look at the connector for the 7990 port. Make sure you have the following set:

  • proxyName
  • proxyPort

 

The proxyName should be the same as what you have listed. The ProxyPort should be in the conf file where the Virtual Hosts are declared.

Hello.

I can't find the server.xml.

 

Did you mean the file "bitbucket.properties" ?

Yeah, I forgot they changed it. You should see connectors in that file. If not, I would search for files with:

  • <Connector port="7990"

There is no file with some lines like "<Connector port=.....".

 

These Files have I see in Jira. There was an Server.xml with exactly these informations... But in BitBucket I can't find some files with this...

What version of Bitbucket are you using? Here is some documentation I found on server.xml and bitbucket.properties that might help find the connectors: https://confluence.atlassian.com/bitbucketserver/migrate-server-xml-customizations-to-bitbucket-properties-897811761.html

Ok, here is the documentation on that version: https://confluence.atlassian.com/bitbucketserver067/migrate-server-xml-customizations-to-bitbucket-properties-979427556.html

Do a Crtl+F and find "Locate your server.xml file." on that page, there is an expandable section right after it that should help ID where the file is.

I have delete all the files and the Database. Then I have installed a new Server 6.8.0

 

then I have checked the Apache2 Config:

 

ServerAdmin admin@bitbucket.domain.eu
ServerName bitbucket.domain.eu

ErrorLog /error.log
CustomLog /access.log combined

ProxyRequests Off

<Proxy *>
Require all granted
</Proxy>

ProxyPass / http://localhost:7990/
ProxyPassReverse / http://localhost:7990/

 

 

It looks very good.

 

and here there is the bitbucket.properties (shared-folder):

 

#>*******************************************************
#> Migrated to database at jdbc:postgresql://localhost:5432/bitbucket?targetServerType=master
#> Updated on 2019-11-07T18:39:03.784+01:00
#>*******************************************************
jdbc.driver=org.postgresql.Driver
jdbc.url=jdbc:postgresql://localhost:5432/bitbucket?targetServerType=master
jdbc.user=bitbucket
jdbc.password=online123/
server.displayName=[BitBucket] - NetzLife.eu - Bitbucket-Server
server.port=7990
server.session.cookie.http-only=true
server.proxy-name=bitbucket.domian.eu

 

But I can't find the BitBucket-Server on the URL " bitbucket.domain.eu ". I must write these URL to find the Server: "bitbucket.netzlife.eu:7990" 

 

WTF...

I have also set the BITBUCKET-HOME on /bin/set-bitbucket-home.sh:

 

BITBUCKET_HOME="/var/atlassian/application-data/bitbucket"

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Bitbucket

Share your software development horror stories!

Hey Community! I work on the Bitbucket product marketing team. With Halloween approaching, we wanted to discuss a topic tailor-made for October: development horror stories. Whether it was a lurk...

1,024 views 11 2
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you