• Community
  • Products
  • Bitbucket
  • Questions
  • I installed bitbucket on my server, WHM cpanel is installed to, icant access bitbucket eventhought service is running.... any help please

I installed bitbucket on my server, WHM cpanel is installed to, icant access bitbucket eventhought service is running.... any help please

 

2 answers

1 accepted

0 votes
Accepted answer

You might want to check the $INSTALL_DIR/logs/catalina.out in your Bitbucket installation. Errors normally get logged there for why the service isn't starting all the way.

Also if you have other applications running on the server you might want to verify and ensure that you don't have both services listening on the same port. If I recall correctly Bitbucket by default will listen on port 8443. You might want to check your $INSTALL_DIR/conf/server.xml and perhaps change the listener port if there is a port conflict with one of your other applications.

Its done, The problem i found in catalina.out thats Bitbucket cant find /user/local/jdk

Thx

0 votes

Generally to debug "it's running, but not responding", you'll need to read the application log files to find out what it is actually doing.  Can you have a look at those?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

211 views 3 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you