Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,406
Community Members
 
Community Events
176
Community Groups

I get the following error importing repo between Bitbucket accounts

  1. 09:33:14 git import for: https://bitbucket.org/project1/repo1/
  2. 09:33:15 Cloning https://bitbucket.org/project1/repo1/...
  3. 09:33:15 Remote Git clone failed: <class 'bitbucket.apps.asyncx.tasks.RepoImportTask.ImportException'>: Command failed. Return value: 128

The name of the original repo have been omited(sorry), the repo is private in another BitBucket account, correct credentials have been used in import page.

4 answers

1 accepted

1 vote
Answer accepted

I believe to understand where the error was now, initially I was using a combination of username(email) and password for my remote account, tried to use my username(non-email) with my account password, tried my account(email) with the APP password but never the right combination which should have been my username(non-email) and a APP password which ended up working.

Using Username and App Password worked for me!

My issue was importing an existing BitBucket git repo to a new BitBucket git repo in the same workspace.  The error was always return code 128 for all my various attempts until I checked the "Requires authorization" checkbox, supplied my BitBucket Username and specified my "App Password" in Password.  Then the import sailed through.

0 votes

Hi everyone,

Any progress on this? I'm having the same issue.

Rgds,

Carlos

Hi @Carlos Leitao 

 

The answer for my issue is marked on top.

Like Carlos Leitao likes this

Hi @Miguel Costa,

It worked just fine. 

Just for ref. I was getting the error while trying to import a repo without ticking the "Requires Authorization" box.

Cheers,

Carlos

0 votes
Syahrul Atlassian Team Jul 27, 2022

Hey @Miguel Costa 

Welcome to the community!

I am wondering what password you used to do the export, is it your account password? If yes, I believe it won't work as we now require App Password as an alternate to account password.

Can you generate a new App Password and use it to export?

Let me know how it goes

Cheers,
Syahrul

Hi @Syahrul 

Thank for the reply, I was indeed using my account details for the other Bitbucket account. I was aware of the app passwords but never gave it a try to be honest, I have followed your advice and created a app password with full permissions to give it a try but unfortunately still getting the same error.

Regards,

Miguel

Syahrul Atlassian Team Jul 28, 2022

Hey @Miguel Costa 

Interesting. Can you grab a screenshot of the Import config? You can mask out the Username/Password and Repo name.

I want to review how your import config and reproduce the issue since I'm not getting any error when I try to do the same import on my end.

Cheers,
Syahrul

Hi @Syahrul 

 

Thanks for the update, please see below:

Import.png

1. I'm using the Bitbucket account username and password for the remote repo, I've also tried to create an app password and use that but getting the same error , sorry for the redacted stuff but it's the best I can do.

2. After I get the following error:

error.png

For now I am currently using the "transfer" feature under the repository settings instead to move them across.

Syahrul Atlassian Team Jul 31, 2022

Hi @Miguel Costa 

Looking at the screenshot, I notice in the Username section, you use your email address instead of your username.

Can you change it to your username? You can find your username under your Personal settings or directly at this link:

It should show your Username under the Bitbucket profile settings.

Let me know if that helps.

Cheers,
Syahrul

Hi @Syahrul 

Thanks for the reply, I have tried it but unfortunately still not working.

Regards,

Miguel

Hello guys,

same issue, any update here?

looks like there is some problem with importing

Syahrul Atlassian Team Aug 11, 2022

Hi @Miguel Costa 

I've created a support ticket on behalf of you to continue the investigation. You can view your ticket here 

As for @Shakeel_Ahmed may I get a screenshot of your import config before we proceed further?

Cheers,
Syahrul

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events