Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


I cannot push to my brach because a merge is in progress


I must admit I'm a novice in Bitbucket and in Git in general. I'm using Sourcetree and working in a repository in Bitbucket.

I'm working with a plugin within a videogame project, for which I am the only responsible of. For the record, the game engine is Unity and the plugin is FMOD (an audio middleware). I'm the only one modifying the relevant files of the plugin (the FMOD project and the audio banks) within Unity.

I have a separate branch for my work with the plugin. There have been changes made into my branch, with a new version of the app for testing. I don't know what I've done, but at this point:

  • If I pull the changes, I get this error:
error: You have not concluded your merge (MERGE_HEAD exists).
hint: Please, commit your changes before merging.
fatal: Exiting because of unfinished merge.
  • If I make a commit, I get this error after a long blue block of text:
fatal: cannot do a partial commit during a merge. 
  • If I try to make a push (which would be useless without committing), I get this (I modified the names of the repositories and client):
Pushing to
= [up to date] Production-MVP -> Production-MVP
! [rejected] FMOD -> FMOD (non-fast-forward)
error: failed to push some refs to ''
hint: Updates were rejected because the tip of your current branch is behind
hint: its remote counterpart. Integrate the remote changes (e.g.
hint: 'git pull ...') before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.

It looks I've started a merge, but I don't know how and how to get out of this.

What I want is to accept any change made by the developers, except from the relevant files for FMOD, which I believe they did not touch (aside maybe for some caches and such), and push my changes for the relevant FMOD files. For a complete noob in git, bitbucket and sourcetree, how do I make this?

Many thanks

1 answer

1 accepted

1 vote
Answer accepted
Saxea _Flowie_
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Nov 02, 2023

Hi @Lucas Rei Ramos

Probably a merge conflict.

Do a `git status` and this should give you more details.

Hello @Saxea _Flowie_ 

Thanks for your hint. I did that, and this is what I get:

On branch FMOD
Your branch and 'origin/FMOD' have diverged,
and have 1 and 141 different commits each, respectively.
(use "git pull" to merge the remote branch into yours)

All conflicts fixed but you are still merging.
(use "git commit" to conclude merge)

Changes to be committed:

and then I get a bunch of files in green (new and modified files).

Then I get this

Changes not staged for commit:
(use "git add/rm <file>..." to update what will be committed)
(use "git restore <file>..." to discard changes in working directory)
deleted: FMOD/Metadata/Event/{0cf32ce5-99c4-475c-8341-43c26548e437}.xml
deleted: FMOD/Metadata/Event/{1f486936-3ba9-4c36-8435-97abae43e129}.xml
modified: FMOD/Metadata/Event/{2ebb0065-18d1-4768-ab74-08b78e92080f}.xml
deleted: FMOD/Metadata/Event/{5f56eb27-cd6d-42ae-824b-ee5def1e5e25}.xml
deleted: FMOD/Metadata/Event/{86691b51-29b7-4840-9f9b-11c2175f74dd}.xml

Untracked files:
(use "git add <file>..." to include in what will be committed)

It suggest me to "git commit", but this still throws an error (haven't tried in Terminal, but in Sourcetree GUI it does, as I pointed out before)

Hello again! Your hint pointed me in the right direction! The problem was with the partial commit. It looks that I had some unstaged files. Staging them and committing worked, or so it seems!

Saxea _Flowie_
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Nov 03, 2023

Nice! I suggest taking a short tutorial on git basics so you become more familiar with the common scenarios,  otherwise it can be very frustrating. I said that from my own experience :).

Thanks! I did sone time ago, but lack of practice isn’t helping. I remember having problems in the past trying to roll back to a previous commit and things like that. Will follow your advice.

Thanks again!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events