Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,300,550
Community Members
 
Community Events
165
Community Groups

I can not "Commit and Push" from Eclipse 2021-12

I am using Eclipse 2021-12 and am trying to "Commit and Push" to my bitbucket; however, it will no longer work. I am using my user name (not email address) and Atlassian password. However I get the message:

'Push to AwardTracker_NJE - origin' has encountered a problem.

Can't connect to any repository:

https//Glyndwr@bitbucket.org/awardtrackeringapplication/butbucketstationlocations.git

(https//Glyndwr@bitbucket.org/awardtrackeringapplication/butbucketstationlocations.git: not authorized)

 

Details:

Can't connect to any repository: https://Glyndwr@bitbucket.org/awardtrackingapplication/bitbucketstationlocations.git (https://Glyndwr@bitbucket.org/awardtrackingapplication/bitbucketstationlocations.git: not authorized)

 

 

1 answer

0 votes

HI @Glyndwr ,

try to edit your git credentials and try again. In order to do that :

To specify credentials individually for each remote

  1. Open Git repositories view,
  2. open "Remotes > origin > <your push url>"
  3. click "Change Credentials..."

push menu

(From User Guide - Resource Context Menu)

 

Hope this helps,

Fabio

Hi @Fabio Racobaldo _Herzum_ ,

 

Thank you for your assistance; however, step 2 does not match with what I see on my screen when I select "Repositories". This is what I see:

 

Screenshot 2022-05-22 170851.png

 

Kind regards,

Glyn

Hi @Fabio Racobaldo _Herzum_ ,

OK, I think you mean to do this in Eclipse. I did this and it requires me to enter my password. When I do I get and error message "Failed to write credentials for 'https://Glyndwr@bitbucket.org/awardtrackingapplication/bitbucketstationlocations.git' to secure store
No password provided."

Kind regards,

Glyn

Hi @Glyndwr ,

yes, that operation is to Eclise side. Here a solution for your current issue https://openwritings.net/pg/eclipse/eclipse-failed-write-credentials-your-git-repo-url-secure-store-no-password-provided

Fabio

Hi @Fabio Racobaldo _Herzum_ ,

Thank you so much for your help. In my case it was untick the Windows 64 bit integration. I was then prompted to add a new password, which I did using the Atlassian password. However, I am still getting the following error when I try to Commit and Push.

Can't connect to any repository: https://Glyndwr@bitbucket.org/awardtrackingapplication/bitbucketstationlocations.git (https://Glyndwr@bitbucket.org/awardtrackingapplication/bitbucketstationlocations.git: not authorized)

Kind regards,

Glyn

I still need help with this please.

Some one suggest that https is no longer supported. So the git connection property in eclipse needs to change to ssh. How do I do this please?

@Glyndwr if your bitbucket is in https you need to use https also in eclipse.

Are you sure that your account has privileges to write in that repository?

@Fabio Racobaldo _Herzum_ I was able to write to it before the resent changes. How do I check that my account has privileges to write in that repository please?

This is still not working.

This is still not working. Please help!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,262 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you