Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

I am unable to delete a repository

I try to delete a private repository in a public project. When i try to delete it under repository settings > manage repository > delete repository  a loading icon appears and nothing happened. Any suggestions?

1 answer

0 votes
Caroline R
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 14, 2022

Hi, @Maximilian F, welcome to the community! 

I've reproduced your scenario (a private repository in a public project) and tried to delete this repository and was able to do that, so we can confirm this is not the reason you can’t delete this repo. In order to further investigate what is happening here, could you please confirm the following information?

  • What is the browser you are using to delete this repo?

  • Could you please share the workspace/repository name masked (with asterisks), so I can identify it?

  • Has anyone else tried to delete this repo?

  • Can you please open the dev tools panel while trying to delete this repo? To do this, right-click the page and click Inspect > open the Network tab > try to delete the repo and check if you receive any error during this process.

Please feel free to share any additional information regarding this case.

Kind regards,

Hi Caroline,

thanks for your quick reply. I am using firefox as browser.
The repo name is A***-***
The other person, who can access the repo tried to delete it first.
I get an internal server error (500) in the network tab.


Caroline R
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 16, 2022

Hi, Maximilian

Thanks for the additional information. I checked this repository and don't see any problem with it. The 500 response usually comes with a Sentry ID code, this code may give us some indication of what is causing this issue. In this case, could you please follow the next steps to find the Sentry ID, so I can further investigate this case?

  • Open the "Developer tools" in the browser you are using (click on the three dots > More tools > Developer Tools): 


  • In "Developer tools", select the Network tab

  • Then navigate to the Bitbucket page that gives you this error (in your case, try to delete the repo)
  • Find and select the request that gives a 5xx response

  • In the Headers panel (after you select the request with 5xx response), check if there is a field named sentry id.

  • If you can provide us with the value of that field, I can look it up in our system for further info.

Thank you.

Kind regards,

Hi Caroline,

I cannot find a sentry id field in the 500 Response. I could send you the whole raw response. Would that be helpful?

Best regards,

Caroline R
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 21, 2022

Hi, Maximilian! 

Thanks for getting back to us. In this case, we can try to delete this repo for you (with the approval of the admin of this content), so I have created an internal ticket for you using the email of your community account. 

You should have received an email with a link to the support ticket. Just in case you haven't received it, please feel free to let me know and I can post the ticket URL here. The ticket will be visible only to you and Atlassian staff, no one else can view its contents even if they have the URL. 

Please feel free to let me know if you have any questions. 

Kind regards, 

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events