Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,620
Community Members
 
Community Events
165
Community Groups

I am not able to generate pr though the commits are visible

I am trying to generate a pull request and all my commits are visible but as soon as i try to create a pr it shows 

'We couldn't load the diff' 

and if i try to merge it without the diff 

'Something went wrong while creating your pull request.'

message is coming?

 

please help

1 answer

0 votes
Caroline R Atlassian Team Aug 17, 2021

Hi, @Swatantra Saurabh! Welcome to the community! 

The “Something went wrong" message usually comes with a 5xx response that shows a Sentry ID code. This code may give us some indication of what is causing this issue. In this case, could you please follow the next steps to find the Sentry ID, so I can further investigate this case?

  • Open the "Developer tools" in the browser you are using (click on the three dots > More tools > Developer Tools): 

devtools.png

  • Then navigate to the Bitbucket page that gives you this error

  • In "Developer tools", select the Network tab

  • Find and select the request that gives a 5xx response

  • In the Headers panel (after you select the request with 5xx response), check if there is a field named sentry id.

  • If you can provide us the value of that field, I can look it up in our system for further info.

Thank you.

Kind regards,
Caroline

ba3f8090bb964193b819239164503ec8 is my sentry id

Hi @Swatantra Saurabh,

Please allow me to step in as Caroline is out of office.

Thank you for the sentry id. I checked it in our system and the error message is "NotFoundError".

Could you please double-check and let me know if the source branch of the PR exists in your repo, and if the destination branch also exists in the repo where you are opening the PR?

This issue may also occur if the pull request has a reference to a commit that no longer exists, e.g. as a result of rewriting history. Is it ok if I run a git gc on both repos (your own and the target repo)? This has often solved issues with the same error.

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,158 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you