Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,811
Community Members
 
Community Events
176
Community Groups

I am facing build error

Am facing the below error

Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.0:compile (default-compile) on project VuramAutomationTestingTool: Fatal error compiling: java.lang.IllegalAccessError: class lombok.javac.apt.LombokProcessor (in unnamed module @0x23396fc0) cannot access class com.sun.tools.javac.processing.JavacProcessingEnvironment (in module jdk.compiler) because module jdk.compiler does not export com.sun.tools.javac.processing to unnamed module @0x23396fc0 -> [Help 1]

P.S: I tried changing my Lombok dependency to 1.18.20 in my pom.xml, still am facing the above issue .

The application is running when i build it through my local, am facing issue only when i run via bitbucket

1 answer

1 vote
Patrik S Atlassian Team May 17, 2022

Hello @Sangavipriya Thyagarajan ,

Welcome to Atlassian Community!

The error you reported seems to be an issue with OpenJDK and the Lombok plugin.

I was able to find the following StackOverflow thread with some suggestions on how to fix the error : 

Accordingly to that thread, you should be able to fix the issue by updating the Lombok plugin used by your project to version 1.18.22

<dependency>
  <groupId>org.projectlombok</groupId>
  <artifactId>lombok</artifactId>
  <version>1.18.22</version>
</dependency>

Also, make sure the docker image you are using in your build has a java version compatible with that plugin. The users on that thread reported that using OpenJDK 16 did work.

Hope that helps! Let me know in case you have any questions.

Thank you, @Sangavipriya Thyagarajan .

Kind regards,

Patrik S

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events