Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How to unassign issue using Bitbucket's Rest API?

I have had success assigning issues through Bitbucket's Rest API. I just set the value assignee with an array containing the uuid of the individual (alternatively using account_id also works). However, I have not had success with unassigning issues using the Rest API. I have tried numerous things:

Saving Issue without any assignee value (essentially undefined, it isn't set). This results in saving the issue successfully, but retaining the assignee value from before (since it wasn't changed).

All other ways that I have tried have resulted in the error: "Bad request: Key 'assignee' None is not a collaborator on this repository." These are some of the things that I have tried:

'assignee' => null

'assignee' => ['name' => null]

'assignee' => ['uuid' => null]

'assignee' => ['account_id' => null]

'assignee' => ['username' => null]

'assignee' => ['name' => null, 'username' => null, 'account_id' => null]

Can anyone tell me what I am missing?

1 answer

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Feb 23, 2022


When you are using JIRA, a user which has not yet been assigned is known as "Unassigned". Are you able to try using "Unassigned" instead of "null" and let me know how this goes? 


- Ben (Bitbucket Cloud Support)

Hi @Ben 

This did not work - I have tried setting assignee to:


All of them return the same error:

{"type": "error", "error": {"message": "Bad request", "fields": {"assignee": "None is not a collaborator on this repository"}}}

This is the endpoint:

Everything else works as expected - its just assignee that doesnt work

Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jul 14, 2022

Hey @Z 

Upon further testing it appears you are correct - when performing a GET request on an issue it shows "assignee: null" in the HTTP response so it only makes sense that the same JSON argument should be able to be parsed using the PUT method.

I have raised a formal bug ticket with our developers. Feel free to "Watch" this issue for future updates:


- Ben (Bitbucket Cloud Support)

Like Z likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events