Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to trigger build from a BitBucket repository that is under a BitBucket cloud team?

I have a BitBucket cloud team and 1 repository containing an Angular app under the team account. Now, i want to build it through VSTS (Visual Studio Team Services) and enable continuous integration. The build fails at the "Get sources" step in VSTS. It succeeds if my repository is directly under the BitBucket account but fails if the repo is under a team account in the main BitBucket account. I have tried specfying multiple service end-points without any success. The error i get in VSTS is the following:

 

git remote add origin https://************@bitbucket.org/********/my-app.git
git config gc.auto 0
git config --get-all http.https://******@bitbucket.org/********/my-app.git.extraheader
git config --get-all http.proxy
git remote set-url origin https://********@bitbucket.org/********/my-app.git
git remote set-url --push origin https://********@bitbucket.org/********/my-app.git
git fetch --tags --prune --progress --no-recurse-submodules origin
fatal: could not read Password for 'https://********@bitbucket.org': terminal prompts disabled
Git fetch failed with exit code: 128

 

I tried putting my machine's key in VSTS->SSH keys section but it didn't help.

 

Also, in BitBucket main account settings->OAuth, i do see VSTS authorization but not under BitBucket team account settings.

1 answer

0 votes
jredmond Atlassian Team Dec 16, 2019

The error message specifically mentions that it wants a password that has not been provided. If you were doing these fetches from the command line, then you would get a prompt, but VSTS has disabled prompts.

Also, the URL listed there is HTTPS, so your SSH key is not relevant to this operation. You could use an SSH URL instead - either `ssh://git@bitbucket.org/********/my-app.git` or `git@bitbucket.org/********/my-app.git` should work, though that will depend primarily on how VSTS expects those URLs. (You'll also need to add that public SSH key to Bitbucket, either to the repo for read-only access or to your user for read-write access.)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,826 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you