Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,945
Community Members
 
Community Events
176
Community Groups

How to increase value of MEMORY_LIMIT in php.ini

I have set up a Bitbucket pipeline, and I am using "image: php:7.4-cli" in my bitbucket-pipelines.yml file. 

Per default, the MEMORY_LIMIT in php.ini is set to 128M, which is too low for my test suite to run, and I run out of memory. 

 

I was wondering if anyone knows how to increase this value to 512M instead? 

1 answer

1 accepted

2 votes
Answer accepted

If someone else has got the same question; in your bitbucket-pipelines.yml, add the following line under your script section: 

script: 
  -
echo "memory_limit = 512M" > $PHP_INI_DIR/conf.d/php-memory-limits.ini

The files stored under conf.d will override the default configuration file with your custom value. 

Thanks this worked also for me.

I have tried first by setting the memory_limit on the CLI but this did not work, although I would expect it should:

 php -d memory_limit=2G /usr/local/bin/composer install

As it seems the set memory_limit in the ini configs have a higher priority...or maybe Composer is doing something in between...did not find it out yet

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events