How to finish Stash installation if you can't get to http://localhost:7990 on Linux server with no GUI

I'm installing Stash on a CentOS 7 server and do not have an XWindows environment installed.  Access to the server is only done through SSH (and of course 80 and 443 since it is accepting "web" traffic)  The final stage of the Linux binary installer says to open http://localhost:7990, but I do not have access to a browser since I don't even have a GUI.  I've tried chaging the host strings in the XML files under <StashInstall>/conf and restarted Stash using the shell scripts provided.

I would note that I do have an instance of JIRA on the same server that ran into a similar issue, but I was able to update the server configs for JIRA to change localhost to <myservername> and restarted JIRA.

2 answers

Regardless of what the installer says, you should be able to get to Stash even by IP or whatever other name the server is known as from a web browser, assuming port 7990 isn't firewalled. eg. http://10.1.2.3:7990/

You are absolutely right. I added a firewall exception to the server and now I'm in business. # firewall-cmd --zone=public --add-port=7990/tcp

0 votes

Hey Jeremy, 

 

You can have access to this interface in many different ways. For example:

 

1 - If you want to open a browser locally, you can use a browser by command line (I like w3m). So, if you don’t have it, you can install by YUM (yum install w3m) and then w3m http://localhost:7990

 

2 - Another possibility as Marcin mentioned, is you access the url using the IP Address instead of localhost. Suppose that your stash server is running over the IP 10.2.1.12, so, just type on your desktop browser: 10.2.1.12:7990 

If for some reason you cannot reach it, maybe you have a firewall or a selinux running (or maybe both). You can check it with:

iptables -nL

getsebool -a

 

If you have selinux, for purposing tests, you can disable it. Change on the /etc/selinux/config the “SELINUX=enforcing”  to “SELINUX=disabled” and than restart the Centos.

If you have iptables running, you can disable it or create the rules to allow stash be accessed by your network. You can do it with the commands:

iptables -I INPUT -p tcp --dport 7990 -j ACCEPT

iptables -I FORWARD -p tcp --dport 7990 -j ACCEPT

iptables -P OUTPUT ACCEPT

 

The third way is you access it by putty + xming. You can get more details about it on this link:

http://www.geo.mtu.edu/geoschem/docs/putty_install.html

 

I hope it helps.

 

Regards, 

Renato Rudnicki

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

631 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot