How to configure Stash to serve the http://localhost:7990 to a PC on my Home network of Win7Pro?

I have downloaded and installed Git and Stash today on my home Windows 7 Pro minitower.

The install was done with all defaults (running as a service). So the login as at http://localhost:7990

I then created a test repo on the pc then used Sourcetree to push. This is all working well. I can open Stash from Internet Explorer of the same computer.

The problem is when I use a different Win 7 laptop to try to open http://localhost:7990, I get 'This page can't be displayed' . ( I have the Homegroup setup so that I can open music or files in the My Documents folders.)

What do I need to do, to allow my laptop to open the Stash Application using IE or Chrome?

Thank you,

Dave

1 answer

1 accepted

3 votes

You need to use the ip or the network name of the machine. Localhost means the local machine. 

Thank you. I tried the ip 192.168.1.4 (Found using the Network Map) but get the same message. I have a NETGEAR WNDR4500 wireless router. Is there something I need to setup?

Are both computers on the same network? For instance, can you go to "Start" >> "Run" >> "Type cmd" >> ping <IP of the other machine>> ? The problem here is network connectivity.

Hi Thiago. Yes, both computers get a ping response from each other. The average is 12 ms. (192.168.1.4 and 192.168.1.24) Should I be able to see a 'Stash' webpage similar to Bitbucket?

You have to type: http://192.168.1.4:7990 and yes, you should be able to see the Stash page.

Hi Thiago, I tried http://192.168.1.4:7990 and internet explorer takes me to the Bing search page. I have Stash up and running. I don't know much about servers. I don't know what to check next. Thank you for your help. Dave

Hello, I searched for how to open a port in Windows 7. Followed a link to Microsoft that said to open Control Panel, search for Firewall. Click on the Windows Firewall result. Then click Advanced Settings. Click inbound rules for the 'atlassian-stash-3.8.1-x32.exe' (TCP protocol) entry. Select the Tab Advanced. I found that the Profile: private was checked, Domain and Public were not, so I checked the Public and Domain. I then modified the 'atlassian-stash-3.8.1-x32.exe' (UDP protocol) entry the same. Now when I enter http://192.168.1.4:7990 in the web browser the Welcome to Stash log on page comes up. It's late, so I didn't log in yet. I wanted to get this information posted to help others that may have the same situation as me. (I also checked the TCP and UDP settings of the inbound uTorrent rules - They have all three profiles checked.) I'll get back to this thread if I have more directly related problems with my Home test network. Thank you Daniel and Thiago, Best regards, Dave

Nice job, Dave. Thanks for sharing, mate! Have a good night! :-)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,764 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you