It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to change MAIN branch in BitBucket?

Mikhail Kopylov Apr 05, 2014

Have a main branch in BitBucket named "trunk" (after import from SVN).

Also have branch named "master" - branched from "trunk".

How to set "master" the main branch in BitBucket and then delete "trunk" branch?

3 answers

1 accepted

7 votes
Answer accepted
Robust Apr 05, 2014
git symbolic-ref HEAD refs/head/master
git branch -d trunk

Simon Puckey Apr 21, 2016
refs/heads/master

NOT

refs/head/master

??

Ramratan Gupta Feb 11, 2019

Is solution working for new branch to be set up as default branch? I need to set new default branch other than master, I need to each time do the same thing as first aswer, need to write and automation script which do the same for 4 repositories.

Ref - https://stackoverflow.com/a/37550604/1589444

54 votes
Jani Hurskainen Apr 06, 2014

In Bitbucket UI:

  1. Select the repository
  2. Select Administration
  3. In Repository Details, set Main branch

Now delete unnecessary branches with git branch -d.

LiAh Sheep Sep 23, 2015

In the updated Bitbucket UI, select *Settings* instead of *Administration* in Step 2.

Like # people like this
James Bush Nov 03, 2016

Check permissions if you don't see the "Settings" link.

Like Evgeniy Artemenko likes this
Sandeep Valapi Jun 13, 2018

Thanks, worked

Like Сергей Русак likes this

Thanks, worked

Dave Sky Nov 19, 2018

Why did I get an email for Carlos' "Thank" reply? I merely replied to Christian's reply on a separate sub-thread.

I notice this thread is marked "Watched" for me... I don't want to auto-watch a thread just because I reply to someone in it.

Goncalo Silva-Dias May 12, 2019 • edited

what is the difference between "main" and "development" branch?

Dave Sky May 16, 2019

I'm not watching this thread yet I'm getting emails for random replies here but not to my replies... not seeing how to unsubscribe from this.

0 votes
Christian Bacher Sep 26, 2015

After changing the main branch - when cicking on "save reporistory details" i get a wired error:

"You can't create repositories under this account."

 

Dave Sky Jul 17, 2018

Seems like you need admin access.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

3,030 views 1 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you