Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to add images to


I am trying to add some images to my file as




but its not working. when i view the readme, all i see is the plain text



please help

11 answers

1 accepted

9 votes
Answer accepted


You can include an image by specifying the path relative to your repository root directory:


Hope this helps.




thanks michael but i still get the plaintext ![picture](img/stormConsole.png) also, i cant seem to be able to escape quotes. i tried using \' but this shows up as \' does stash render markdowns differently ?

Like Kamil_Woś likes this

I've just checked it again: ![Alt text](path/to/your/img.png) works as intended. Do you have it on a separate line?

No, it doesn't show image in README on project page. I've tryied both relative links and absolute path to dropbox hosted image (http://*.png) - doesn't work... This is sad. 

Ilya, I was having same problem. If I removed all space in front of the tag, my image started showing up. Apparently, you can't indent.

Like # people like this

![alt text](images/successful.png)

This worked for me.

I had the same problem and tried a lot (relative path, upper/lowercase etc.).

What solved it finally was adding the alternative text.

As Michael said, this is a valid format working locally in editor preview and remote on Stash/Bitbucket:



Dear all,

Same problem since new version of bitbucket.

Last week, no issue to display the picture.

Now, the issue is the picture is not displayed.

To get back the picture, we need :

- Edit the file

- press CANCEL

Then the picture is displayed again.



the path is : ![home](images/home.png)

Thanks if anybody could highlight me about this.


Best regards,


Like lennart_papoo likes this

Changing my comment to STILL NOT WORKING.

It still will not render correctly on the overview page.



Yest it is.

Without :

- Edit the file

- press CANCEL

No pictures.


Best Regards,


This does not work as intended. Maybe it's working in existing README's but not new ones.

I added an image to my repo in a folder. I added the markdown


When I view my readme on bitbucket I get a broken image link. I opened the inspector and the path/image are correct! The file is requested and returns a 200. Except that the content type is text/html :(

It appears that the markdown parser is interpreting the code incorrectly.

@Boujraf Youssef Your fix works temporarily. On reloading the page, the images get lost again.

same problem here, it was working but with the new design the images disappeared...

Same problem here

Anyone work this out yet?

I'm having the same issue. It does work if I go to the Readme file, push Edit, then push Cancel. Otherwise, it's just showing the alt-text and a broken image icon. I mean, if nothing else, can the broken image icon go away and the alt text just behave like it normally would on a website?

It does work, but the problem is it only works in the master branch. If you have a feature branch and try to test it out, it will appear as a broken link. When you merge to the master, your image will show up. Atlassian should fix this.

Like Lourenzo Ferreira likes this

Not only does it only work in the master branch, the image still won't display.  You  have to actually click on the alternate text (which is hyperlinked) to the image file, which then displays properly in a new window.

EDIT:  I had an extra [] pair around the alt-text; weird behavior for sure... 

But still only works with master.

can we specify the width and height on this: `![picture](public/images/image.png)`

Like # people like this

Get the full path by navigating to your image file, push 'raw file'-button right of the page, copy the path except for the very end (e.g. image.png?at=refs%2Fheads%2Fmaster). In general the path should be https://......../[project_name]/raw/[image_folder]/[image.png]

Like # people like this

This works only in preview mode (while editing the file inside the bitbucket itself)

Thank you a lot. 

Great. Worked for me too. Thanks google street view

This works for me:


ImgName = whatever you want

AbsoluteURL = can copy this from browser, go to the image in your repository, open it and copy the link


ModifiedAbsoluteURL = Take the AbsoluteURL and replace "src" with "raw"


Now your image should be displayed in the ReadMe.

Worked for me after trying a million other things. Thanks!

Worked for me. Thanks!

Thank you very much! this solution worked for me.

A relative path works just fine, if you are on the master branch.




I changed the file in the development branch, but when pushing changes the images are not showing up. The reason is: because BitBucket looks for the raw images in the master branch.

This worked for me. I used the absolute path suggested by @Mikko Salonen along with the following format:

.. figure:: https://absolute/path/to/image.png
   :alt: alias of image

How does Atlassian even dare to claim projects are migrating from GitHub into here if it does not support such simple feature...

It's very simple

Just upload your image to the repository root, and link to the filename without any path, like so:


In each repo's Issue Tracker under Settings, I added an image to the "No issue tracker":

Screen Shot 2019-06-17 at 11.51.51 PM.png

That provided a link that I copied and pasted into the repo's file. This works for me and is the same technique some use on GitHub.

Removing spaces from the paths solve this issue for me. Still surprising that in 2k19 we still got issues with spaces inside the path.

Check the case of both the path and filename are correct.


I had trouble getting a swagger screenshot to load in our on bitbucket server. The image was one folder deep from root in the resource folder. Resources/SwaggerUI.PNG

When looking at the md file I had, I noted that the case of the path and file name was wrong.

So `resources/swaggerui.png` did not work but setting the correct case did `Resources/SwaggerUI.PNG` 

## Swagger


Simon, I'm also using Bitbucket Server and can only get images to work in markdown when using paths relative to the current file. repo-relative paths don't work, and external links dont work. Is this your experience as well?

It's rather unfortunate, bc it forces us to put images in our git repos, which is less than ideal. I'm using png exported from - it would be better if I could refer to the file stored elsewhere IMO.

I don't see anywhere in Bitbucket docs or in community about this limitation.

Yeah our readme is at root too. So we're in the same boat. Could only get the image to render when the path is relative but also when the case matched.

It's rather unfortunate, bc it forces us to put images in our git repos, which is less than ideal. I'm using png exported from - it would be better if I could refer to the file stored elsewhere IMO.

Could not agree more.

It is 2020, is there any way to resize on bb?

Like sharrikk likes this

![picture](img/abc.png) works.

Apparently, it was due to case sensitivity in my case. Changing jpg to caps worked on my test repo. So make sure your path and name of the file is exactly as it is in the repo.

Aparently, bitbucket does not like the minus character when trying to embed an image into a markdown file.

This does NOT  work (has minus char in filename)

![Descrition](folder/file-name.png) works in bitbucket.

This works (minus char removed)

![Descrition](folder/filename.png) works in bitbucket.



Could you please tell me how can I directly upload an image to an existing directory. I can add images to a comment description but I don't see a way to add it to any repo.

You would have to push the image to the repo same way you'd push the code. Cannot add image from the bitbucket UI. You'd have to do it either using sourcetree or git commandline.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

2,111 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you