Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I run bitbucket pipelines for every 5min

Edited

We have critical test pipelines that should run every5min . When I open schedule I see only Daily , Weekly, Hourly . 

1 answer

0 votes

@mounika.nallagundla

Pipelines UI contains wide-used propositions for period. For custom schedule you can post this schedule using bitbucket api (doc https://developer.atlassian.com/bitbucket/api/2/reference/resource/repositories/%7Bworkspace%7D/%7Brepo_slug%7D/pipelines_config/schedules/#post ).

 

Regards, Galyna

@Halyna Berezovska  thank you very much.

Could you please provide me a piece of code example for pattern or more example information on this if possible.

Thank you

@Halyna Berezovska where exactly we can hook up this in our Repository ?

@mounika.nallagundla for example, you can create a custom pipeline that is posting a schedule. But it actually can be done only once, if you're not gonna to remove it.

But anyway, to automate this more, in bitbucket-pipelines.yml you can write something like this:


schedule-pipeline: &schedule-pipeline
step:
name: Schedule
script:
- curl -x POST -d '{"cron_pattern": "...."}' url
custom
:
schedule-pipeline:
- <<: *schedule-pipeline



 The url and request data can be found here https://developer.atlassian.com/bitbucket/api/2/reference/resource/repositories/%7Bworkspace%7D/%7Brepo_slug%7D/pipelines_config/schedules/#post

.

Regards, Galyna

Like mounika.nallagundla likes this

@Halyna Berezovska Thanks for the above reply. We are experimenting with it .

One more question regarding Pager Duty Integration with Bitbucket. When I see  Pager Duty integration It is hooking up with Repository not with specific pipeline run . If you provide any solution for this(pipeline test level) that will be big help for us .

Thanks.

@Halyna Berezovska I have given Workspace UUID & Repository UUID in the url .

Note: I am not posting actual values here for the privacy but tried with actual values got Resource not found.

custom: 
Every-Five-Minutes-Schedule:
- step:
name: Five Minute Schedule
script:
- curl -x POST -d '{"cron_pattern":"0 0/5 * * * ?"}' https://api.bitbucket.org/2.0/repositories/{workspace UUID}/{Repository UUID}/pipelines_config/schedules/

It’s returning with “Resource not found” error.

Let me know if you need more info.

Thanks!

@mounika.nallagundla we don't try it with repository id and workspace id, but with workspace name and repository name. I also tried with workspace uuid and repository uuid, it also works.

SO there could be two issues in your request:

- something is wrong with authorization scope. perhaps you did not give required right for your app password that you use on authentication

- misstyp in url. my urll looks like:

https://api.bitbucket.org/2.0/repositories/{WORKSPACE_UUID}/{REPO_UUID}/pipelines_config/schedules/

or

https://api.bitbucket.org/2.0/repositories/workspace/repo/pipelines_config/schedules/

Check also the url  contains proper workspace uuid and repository uuid. You can find them , for example, in OpenID COnnect tab of repository - this tab gives such info.

However, it is easier and more handy to use names.

 

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

190 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you