Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,742
Community Members
 
Community Events
176
Community Groups

How can i use openVPN in bitbucket pipelines

Edited

Hello , i'm trying to implement an CI tests on bitbucket pipelines 

To do so ; i need to connect the pipelines to my OpenVPN server to be able to communicate with other client 

Here is my bitbucket-pipelines.yml  : 

image: alpine:latest

pipelines:
default:
- step:
     script:
       - apk update
       - apk upgrade
       - apk --no-cache --no-progress add bash curl ip6tables iptables openvpn shadow tini sudo
       - adduser --system --no-create-home vpn
       - addgroup -S vpn
       - mkdir /dev/net
       - mknod /dev/net/tun c 10 200
       - chmod 666 /dev/net/tun
      - cp cloud.conf /etc/openvpn/
      - sudo openvpn --config /etc/openvpn/cloud.conf

I tried with/without sudo ( the pipelines is already in root ). with/without adduser/addgroup . 

I also tried it with Ubuntu image 

the problem remain : 

Wed May 15 09:02:50 2019 WARNING: Since you are using --dev tun with a point-to-point topology, the second argument to --ifconfig must be an IP address.  You are using something (255.255.255.0) that looks more like a netmask. (silence this warning with --ifconfig-nowarn)
Wed May 15 09:02:50 2019 ROUTE_GATEWAY 169.xxx.1.1
Wed May 15 09:02:50 2019 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1)

Wed May 15 09:02:50 2019 Exiting due to fatal error

 

Is someone know how to implement an openvpn client in bitbucket pipelines ? 

 

2 answers

1 accepted

3 votes
Answer accepted

Hi @Abdoulaye Tandian

I don't have good news, unfortunately.
Long story short, this is not possible in Pipelines at the moment due to infrastructure limitations based on security. This subject was discussed in this post:

Philip is one of our developers. He shared an enhancement request already tracked in our system:

And a survey where more information could be collected so they can better evaluate and prioritize this issue among others.

The only option we have now is to leave comments on that enhancement request, fill the survey requested by Philip and wait.

Hi @Abdoulaye Tandian

Thank you for following up!
If you think this response will help others in our community, please click accept this answer.

Have a good one!

is there any update on this? 

Hi @Ajay Kumar

The channel to get updates on this implementation is:
#12753 - Allow customers to connect the pipelines builds to their own VPN server.
That is the channel our developers use to deliver their news and update the status of the issue/feature/bug.

That suggestion will be prioritized among other requests considering our Implementation of New Features Policy.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events