Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How can I use Bitbucket as private maven repository?

I tried to leverage Bitbucket as private maven repository for the gradle project. Below are steps I tried to setup in Bitbucket and gradle project.

Bitbucket 5.0.1:

1. Create a project "repo" in Bitbucket and enable project having public access with read only

2. Create a repository "maven-repo" in Bitbucket

3. Commit com/company/shared/utils/1.0/utils-1.0.jar to "maven-repo"

Gradle Project:

1. Add Bitbucket "maven-repo" in build.gradle

repositories {
        maven { url "http://bitbucketServer:9000/projects/REPO/repos/maven-repo/browse" }

2. Add utils-1.0.jar as dependency in build.gradle

dependencies {
             // http://bitucketServer:9000/projects/REPO/repos/maven-repo/browse
             compile ''

However, I got "Could not resolve:". 

3 answers

Try this:


Sounds thats work, I will try it later.

By same logic we shouldn't use bb pipeline or anything else, because initially bb was designed to do only source control..

I am using  version 0.2.5 to deploy and consume the artifact from my private bitbucket. Following the same steps as given in the documentation


`Could not resolve dependencies for project The following artifacts could not be resolved: Could not find artifact in xxx_repo (`


From my research, I found many suggested the problem in repository URL so I changed to from this URL I am able to access the repo but the compilation fails with an error saying zip END header not found

`Compilation failure:
[ERROR] Error reading /home/msuser1/.m2/repository/com/aaa/bbb/3.0/bbb-3.0.jar; zip END header not found`

And too many warning saying checksum validation failed.

`[WARNING] Could not validate integrity of download from Checksum validation failed, expected <!doctype but is 2f947caee42a20633fb9c412ew53591f64b8c4481`


**What is the exact URL for consuming the artifact from a private bitbucket?**

**Can anyone provide complete working steps to deploy and consume artifact from private bitbucket using wagon-git?**

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

2,570 views 1 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you