Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Hello

We need use bitbucket repository for helm repository.

So we have Private bitbucket repository. I created App Password and try to add Bitbuket repository to helm and got the following issue:

# helm repo add helmstore https://ruslanshevchenko:<app_password>@bitbucket.org/ruslanshevchenko/affiliates/raw/master/
Error: Looks like "https://ruslanshevchenko:<app_password>@bitbucket.org/ruslanshevchenko/affiliates/raw/master/" is not a valid chart repository or cannot be reached: Failed to fetch https://ruslanshevchenko:<app_password>@bitbucket.org/ruslanshevchenko/affiliates/raw/master/index.yaml : 403 Forbidden

 

Can you provide manual how to correct add Bitbucket repo to helm.

Thank you.

3 answers

0 votes
jredmond Atlassian Team Mar 02, 2019

403 implies that the application password you're using here doesn't have the correct access for that repository.

But if I did git clone - all works fine.

But if I did git clone - all works fine.

Hi! @Ruslan Shevchenko any upate on this?
I'm also trying to get a private bitbucket repository working as Helm repository.

Currently it seems, that it is not possible.

The only way I've found to access raw files is via API:

curl -s -S --user {USER}:{APP-PASSWORD} -L -O https://api.bitbucket.org/2.0/repositories/{USER|ORGANISATION}/{REPOSITORY}/src/{BRANCH}/{PATH-AND-FILENAME}

Hi!

 

I think that's the correct way right now.

helm repo add {REPONAME} https://api.bitbucket.org/2.0/repositories/{USER|ORGANISATION}/{REPOSITORY}/src/master/ --username {USER} --password {APP-PASSWORD}

Above line is working fine for me. Just make sure that charts.yaml is in the root directory of your repository.

Like Sai Sarath Vadlapatla likes this

what URL are you passing when you create the index? 

 

{code}
helm repo index --url <my repo URL}

{code}

I just created a new repository. Then:

cd {PATH_TO_REPOSITORY}
mkdir charts
helm package {PATH_TO_CHART_1} --destination charts
helm package {PATH_TO_CHART_2} --destination charts
...
helm package {PATH_TO_CHART_N} --destination charts
helm repo index
git add charts index.yaml
git commit -m 'initial commit'
git push

EDIT: I don't use this anymore, I have switched over to Azure Container Registry. The helm part is still in preview, though.

yeah, the making is the easy part.

Try using it. helm3 spits it back out.

Sorry, I never tried it with helm v3. Back then I used helm v2 because helm v3 was in beta state and it worked fine. As I mentioned before, I moved on to Azure Container Registry, which supports helm repositories in preview (helm v2 and v3, but no git shorthash in chart versions).

@Josef Schabasser 

helm repo add {REPONAME} https://api.bitbucket.org/2.0/repositories/{USER|ORGANISATION}/{REPOSITORY}/src/master/ --username {USER} --password {APP-PASSWORD}

Thanks for updating the solution for helm repo add via using an app password.
I was looking for a solution from the last week. Finally, I got it.


Like Anish kumar Mourya likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,880 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you