Having trouble cloning a new BitBucket hg repo using SourceTree

I'm just getting started with BitBucket, Mercurial, and SourceTree.

I created a BitBucket account, created a fresh hg repository, and downloaded SourceTree. During the SourceTree installation and set up process, it registered (and seemed to successfully find / log into) my BitBucket account, and it found the new repository.

It suggested cloning that repository and offered to do it, and I'm trying to let it do that, but I can't get past that dialog successfully.

No matter what destination path I give it, it either says the path doesn't exist, or it's not empty. The path is empty, I created the folder just now, but when I select that folder, I get a dialog..

Title: "Cannot clone into non-empty folder"
Message: "The destination path (..the path I specified..) already exists and is not empty. Please choose an empty or new folder into which to clone."

..but the folder is empty, I just created it. And if I specify a folder that doesn't exist yet I get a different error dialog that says the destination folder doesn't exist.

Help?

Huh, I just tried typing in a non-existing sub folder of the folder I just created, and magically, this time, it got past the destination path problem (even though I swear I just tried that and it didn't work.. does the parent folder of the destination folder have to be empty? Does the parent folder of the destination folder have to be the same name as the destination folder?), but now I'm getting a different dialog..

Title: "Error"
Message: "warning: bitbucket.org certificate with fingerprint (..long hex string..) not verified (check hostfingerprints or web.cacerts config setting) abort: http authorization required."

 

I was really hoping to get into a set up that I could easily walk remote, non-technical teammates through getting going over the phone. We're all working in Windows, not Linux or OSX. The various graphical user interfaces provided by hg and Atlassian seemed like a great idea. If I have to try to walk people through installing command line tools, and modifying their system environment path variables so that the command line tools are available when they use a command prompt, and then opening a command prompt and typing in (or even pasting in) command lines.... that's really going to be a major pain in the butt for all concerned.

"Non-techies using a version control system!?" Yeah, long story, please don't ask.

"You can't use netmeeting, joinme, logmein, gotomypc..?" Maybe, but not very easily.

"Why aren't you using Git like everyone else?" I was hoping that Mercurial would handle distributing updates to images and various other binary file types more efficiently than Git does. And Git is very command-line oriented, and I'm trying to escape the command lines.

 

1 answer

1 accepted

Had the same problem and the answer was almost infuriatingly simple.

Don't create a new folder, just add it to the address:

C:\yourinstallfolder\addnewfolder

And off it goes.

Seems to have trouble if you have already created the folder using Windows.

I discovered this by trial and error shortly after writing this. I guess I should've come back and said so. Felt kinda dumb at the time, as I recall, although I was slightly annoyed, too. =/

I can't add anything to the address :/

error.png

Josh2008 I'm New Here Dec 14, 2017

Same problem here.

unable to add to dialog.

Googled still no answer to this.

So uninstalling and trying something else.  :( :(

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

705 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot