Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,555,235
Community Members
 
Community Events
184
Community Groups

Gradle build daemon disappeared unexpectedly (it may have been killed or may have crashed)

Allen H
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 08, 2023

 

The pipeline has been set to disable the daemon, but the daemon is still enabled during the execution process, and an error is reported. What is the wrong setting?

 

The error message is as follows:

```

----- End of the daemon log -----
FAILURE: Build failed with an exception.
* What went wrong:

Gradle build daemon disappeared unexpectedly (it may have been killed or may have crashed)
* Try:

> Run with --stacktrace option to get the stack trace.

> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
* Get more help at https://help.gradle.org

```

Pipeline yml :

- step:
name: building
script:
- export GRADLE_OPTS='-Dorg.gradle.daemon=false'
·····
      - ./gradlew publishBundle --track internal

1 answer

0 votes
Erez Maadani
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 08, 2023

Hi @Allen H 

It's possible that your gradle daemon had started running before you exported the `GRADLE_OPTS`. Try stopping the daemon before calling your gradle command:

    script:
- export GRADLE_OPTS='-Dorg.gradle.daemon=false'
·····
- gradle --stop
      - ./gradlew publishBundle --track internal

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events