Hi,
As we well known, the support of Git over https is ended and we are facing problems in our Bitbucket pipeline.
We have configured three submodules in our main repository and we have configured these submodules over https because we cannot use ssh (as in many companies happens). Locally is fine, because we have configure the APP Pasword, and works well.
However, I do not find a way to configure the same on the pipeline, it returns the following error:
CURRENTLY:

The configuration that I have is:

BEFORE:
What we had before, and it is not longer working is:

It was a workaround, to reconfigure the submodule to use Git over ssh.
For that solution also we had configured ssh keys between repositories to make them accesible.
I have tried many different approaches without success.... any suggestion?
Best regards,
Javier