Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Git pipes failing to deploy -- can't connect to SSH server

youcanread September 16, 2023

Today all attempts to push to my server have failed, and the error message at the point where the deployment fails says this:

ssh: connect to host $SERVER port 22: Address not available
lost connection
✖ Deployment failed.

The last time I pushed to the server the deployment was successful, but it gave a warning message:

!!! WARNING: This is probably not the right ssh server!
It may be painfully slow as a result.
Please check the member interface for the correct ssh hostname to use with your site.

I'm not sure how long that message has been showing up, but it wasn't there are year ago.

How do I fix this? I haven't made any changes to my configuration since the last time it worked.

my bitbucket-pipelines.yml file looks like this:

image: atlassian/default-image:3

pipelines:
default:
- step:
name: Deploy artifacts using SCP to PROD
deployment: production
script:
- pipe: atlassian/scp-deploy:0.3.3
variables:
USER: $USER
SERVER: $SERVER
PASSWORD: $PASSWORD
REMOTE_PATH: '/home/public'
LOCAL_PATH: '${BITBUCKET_CLONE_DIR}/*'

 

1 answer

1 accepted

0 votes
Answer accepted
Syahrul
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 18, 2023

G'day @youcanread 

I notice you are using an outdated pipe version, so please update that to the latest version and enable debug options to investigate further why the connection failed. 

Please find the following repository for more information on the latest pipe version:

https://bitbucket.org/atlassian/scp-deploy/src/master/

Also, to enable debug mode, simply add DEBUG: true as the following example:

- pipe: atlassian/scp-deploy:1.4.0
  variables:
    USER: '<string>'
    SERVER: '<string>'
    REMOTE_PATH: '<string>'
    LOCAL_PATH: '<string>'
    DEBUG: 'true'

I hope this helps.

Regards,
Syahrul

youcanread September 20, 2023

Thank you. Do I have to do anything to update the pipe version other than update the number there? I did that and added debug: 'true', and it's giving me new info, but I'm not sure what to make of it. Is there something wrong with my SSH configuration?

debug1: Connecting to $SERVER [***.**.***.**] port 22.

debug1: connect to address ***.**.***.** port 22: Connection timed out

ssh: connect to host $SERVER port 22: Connection timed out

scp: Connection closed

✖ Deployment failed.

 

youcanread September 20, 2023

I figured out the issue: my host provider changed the server address without telling me so I just needed to track that down. Thanks for the help.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events