Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,300,666
Community Members
 
Community Events
165
Community Groups

Git: Suddenly receiving "You need to verify your account" 403 error

We have a custom software that periodically checks a Bitbucket repository via https. It always uses the same user and password.

Out of nowhere, it has begun receiving this error when attempting to talk to the remote:

remote: You need to verify your account before logging in. Please check your inbox for the verification email.
fatal: unable to access '<remote url>': The requested URL returned error: 403

(replaced actual remote url with brackets)

Unfortunately, the person who created this account left the company long ago, and I don't know the email associated with the account.

Questions:

  • Does anyone know why this may have started? I believe it began today, after being reliable for years.
  • Any tips for resolving this issue? 

Thank you!

2 answers

1 accepted

Here is the resolution: 

  • Finding the email associated with the account
    • As it turned out, this was super easy for our Bitbucket admin to do.
  • Why this started happening on 10/28
    • According to Atlassian support, we were seeing this error because Bitbucket says you can only go so long without logging in to the account before they will stop letting you pull and push using that credential. 
    • We had gone an unknown--but probably very long--amount of time without signing in.

There was an additional complication for us when we tried to sign in to Bitbucket:

  • When I tried to sign in to Bitbucket as prompted by the error message received by Git, I discovered that Bitbucket was saying "We sent a signup link to you" instead of letting us log in.
  • Atlassian support explained that this was actually Atlassian sending a signup link, not Bitbucket. Basically we had created this account in Bitbucket a very long time ago, and at that time you could create a Bitbucket account independently of creating an Atlassian account.
  • At some point since we created that account in Bitbucket, Atlassian made it so that you had to have an Atlassian account in order to access Bitbucket.
  • Once we followed the signup link and created an Atlassian account for our KetraCM email account, we were able to sign in to Bitbucket. 

After that, we were able to "verify" the account. Then we could pull from the repo again using the existing remote URL.

Thanks to Philipe Trinh on the support team for working through this with us!

0 votes
Caroline R Atlassian Team Oct 29, 2021

Hi, @Nathan Caldwell,

I saw that you created a ticket with our support related to the same question, so to avoid any possible misunderstandings or miscommunication that may arise from discussing the same matter on two different platforms, let’s focus on the ticket instead.

Once the ticket is resolved, feel free to share the resolution here to help other community members that may have the same issue. 

Kind regards,
Caroline 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,262 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you