Getting my invited user onto Sourcetree

I'm new to BitBucket and SourceTree. I created a repositority. I checked my project into it. I invited a new user, who was not formerly a user of BitBucket and SourceTree. I watched him create an account for both, in response to the invitation. I can confirm from my Users & Groups page that he has write access to the repository. But then he logs in to SourceTree using his credentials and can't see anything. Under Remote it shows nothing. What does he need to do to make his SourceTree aware of the repository I shared with him, so he can check it out?

1 answer

0 vote

Hi Ken! Can you confirm that he's using the same Atlassian account for both his Bitbucket and SourceTree accounts? Can you also ask him to refresh SourceTree by clicking the Cog icon > Refresh when in the Remote tab.

If he still can not see the repo, can you let us know which version of SourceTree and which OS is he using?

Cheers,

Ana

He can see my repo via Bitbucket website, but not in Sourcetree, even after the Refresh.  Sourcetree 2.5.1, MacOS 10.12.5.

Updating to the latest sourcetree 2.5.3 didn't help.  Remote view shows Bitbucket (correct account name) and nothing inside it.

We used the Checkout/download button on the website and it said "check out in Sourcetree" and went through a bunch of stuff... and now Sourcetree can see the checked out copy under the Local tab.

 

And yes, he confirmed that he was using the same account for Bitbucket and for Sourcetree.

Further news: since we couldn't SEE each other's repositories, we tried using SourceTree to CREATE one.  results: "invalid slug". I'll have to tell you, this is among the most uninformative error messages I have ever seen. What is a slug? Why is it invalid? What did I do to create this error? NO HELP.

I tried both "Catamouse", matching the name of the repository I was trying to work with,  and "Catamouse1", a name I had never used in any fashion before. Same result, both ways. My partner tried "catamouse", and succeeded. Do you understand why?

 

Hi Ken,

The repository slug is a very precise technical description of what's essentially the name at the end of the URL. This is returned from Bitbucket and not SourceTree itself when there are invalid options (which should be listed) present in a proposed name. 

Unfortunately the Bitbucket Cloud API has a lowercase only limitation which that team is tracking. SourceTree has addressed this for branch creation but not repositories. Please file a ticket (or several) at https://jira.atlassian.com/browse/SRCTREE for us to investigate this in a future release. 

Thanks,


Brian Ganninger
Senior Mac Developer, SourceTree

You are affected by this known issue we are tracking - https://jira.atlassian.com/browse/SRCTREE-4313

We will consider fixing this for an upcoming release.

 

Thanks,

Manjunath
Mac Developer, SourceTre

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

714 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot