Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Getting 400 from proxy in a custom pipe

I created a custom pipe that creates reports using /report/{reportId} Bitbucket API endpoint. When I am running the pipe container locally with authentication everything works, but when it runs in an actual pipeline with proxy 'http://host.docker.internal:29418' I get 400 response, and the following is the body of the response:

<html>
<head><title>400 Bad Request</title></head>
<body>
<center><h1>400 Bad Request</h1></center>
<hr><center>nginx/1.15.5</center>
</body>
</html>

When running with curl, it outputs this error: `Received HTTP code 400 from proxy after CONNECT`.

How can I find out what I am doping wrong?

1 answer

1 accepted

1 vote
Answer accepted

Found the problem - when working with the proxy, the call to BB API needs to be sent over http, not https 🤦🏻‍♂️

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

⭐ Calling all Bitbucket and DevOps experts: Special showcase opportunity ⭐

Hi, Bitbucket community! Are you a DevOps practitioner (or know one in your network)? Do you have DevOps tips, tricks, or learnings you'd like to share with the community? If so, we'd love to hea...

1,514 views 4 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you