Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,658
Community Members
 
Community Events
176
Community Groups

GIT is missing commits that do exist on the Bitbucket website?

2 hours ago I committed and pushed to my Bitbucket repo.

But now, I suddenly cannot get access to commits on the same repo newer than about a year ago.
I've tried: Tower, Sourcetree, VS Code (Source Control) and the command line.

What the website is showing (identifying information redacted):

Schermafbeelding 2022-03-28 om 14.18.04.png

What the command line is showing (with `git log origin/develop -3`, showing the 3 most recent commits on the same branch) :

Schermafbeelding 2022-03-28 om 14.22.12.png

This seems like a bug on the Bitbucket side of things, however I've done a pull without thinking and now all work from the last year is missing locally.

What the ..?

2 answers

1 accepted

0 votes
Answer accepted

Of course, 5 minutes after posting this things work fine again. I guess some monkey threw a wrench into Bitbuckets cogs and now it has come loose.

Keeping the question up in case someone else runs into this too: it may fix itself, automagically!

0 votes

Hi @eelkenet and welcome to the community!

I'm a bit confused about what the issue was. The screenshot from the Bitbucket repo (website) shows recent commits, however, your screenshot from the command line shows older commits.

Were you unable to pull the newer commits locally?

We do have a bug with the UI rarely missing commits due to a race condition: https://jira.atlassian.com/browse/BCLOUD-19548 which can be solved by pushing a new commit or branch to the repo.

I am unsure if this is the bug you came across, as it's not clear whether you were missing commits locally or on the website?

Kind regards,
Theodora

Hi @Theodora Boudale

Thank you for reaching out. My issue was the exact opposite from the bug you mention, it seems.

What happened was the following: In the hours before this issue, I had made some changes locally, committed and pushed to the remote. Then when I pulled, to make sure all was fine, all commits from ± the last year were removed from my local repo.

Trying to figure out what on earth happened, I noticed I could see my most recent commits as still being listed on the Bitbucket website. However, I could not list, nor pull them from the remote Bitbucket repository. So the Bitbucket website and the Bitbucket repo were completely out of sync.

I tried both with a shell and with GUI tools such as Tower and Sourcetree.

I figured it might be some syncing issue on your end, but after about half an hour I decided to document it and post this question. Then — right when I had posted it, suddenly my newer commits were showing up again in Sourcetree.

Hi @eelkenet,

Thank you for your reply.

The command 'git log origin/develop' will display the log of the remote branch develop, but its output depends on the remote refs that exist in the local clone. It sounds like the local refs may have been corrupted, I am unsure though why 'git pull' was not updating them properly.

It's hard to troubleshoot this now as the issue is no longer occurring, but please feel free to reach out if this ever occurs again.

The thing I would suggest checking first in such a case would be: take a fresh clone of the repo, checkout the branch with the issue, and pull changes -- do you see the same commits as in the remote? That would be to narrow down whether the issue seems to be specific to the local clone or not.

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events