Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

GIT LFS in Bitbucket Pipelines

Hello everyone, I would like to know if any member of the community was able to deploy using the pipe: atlassian / ftp-deploy: 0.3.0 in repositories that use git lfs to store large files?

PROBLEM: Apparently the bitbucket pipelines does not yet have support for git LFS, we are trying to deploy to our homologation server, but the images are not being carried out the normal conversion at the time of the ftp transfer. Below is the code we use in the pipeline:

image: php:7.1.29
name: Executar-deploy-Homolog-SCS
deployment: HOMOLOG - DEVSCS
pipe: atlassian/ftp-deploy:0.3.0
LOCAL_PATH: "dist"
DEBUG: "true"

After a commit the above pipeline is executed, the output we have on our server with the LFS files from the repository is not as expected, following images below:


Problema_Pipelines_Montagem.png SOLUTION: After some research I was able to verify that the pipeline executes the following command (image below):


GIT_LFS_SKIP_SMUDGE=1 git clone won't fetch all binary files by default

Would it be possible to remove this parameter during the pipeline setup? Is this the real cause of the problem?

1 answer

1 accepted

4 votes
Answer accepted

Hello @kaique_tavares ,

Thanks for reaching out.

It looks like you didn't specify a property to enable LFS, as described on this page:

lfs: true

There's also a blog post with little bit more details on how that works.

Hope this helps.


I can confirm this works.  I have the same in my own bitbucket-pipelines.yml

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Calling any interview participants for Bitbucket Data Center

Hi everyone,  We are looking to learn more about development teams’ workflows and pain points, especially around DevOps, integrations, administration, scale, security, and the related challeng...

505 views 6 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you