From today, my build fail on an unexpected EOF, without any commits

Hello, I didn't make any changes on the code, and a bug appears during the bitbucket pipelines deployment.

I hit rerun on one of my old commits that worked yesterday, and the builds fails today.

Screen Shot 2018-01-23 at 16.58.26.png

This is where it fails, on a yarn run build during the build of the dockerfile.

I tried to put size : 2x in the pipelines options, thinking it was a memory issue, but it didn't change anything.

I think there is something wrong with the update we had on deployment but I can't find it.

1 answer

0 votes

 

Hi Basile, I've seen you replied in our bug tracker:

 

Here is the work around for the moment :

Make your build inside the bitbucket pipelines, and then just take this build directory you have, and create your docker container adding this build directory inside.

Size 2x works for bitbucket pipelines service but not for the docker container inside. The docker containers are blocked to 1gb of ram, so you need to make your hardcore build outside of a docker container.

There is a feature request we need to upvote so they can make the docker container size dynamic : https://bitbucket.org/site/master/issues/14752/ability-to-specify-a-specific-memory-usage

Please keep watching that page for any updates we might have in the future.

Best regards!

Ana 

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

246 views 3 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you