Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Error when trying to log in

Preston Morris_ Jr_ June 6, 2023

Our Bitbucket logs in using Jira.  Yesterday, I changed our JIRA instance to route traffic through a proxy.  This made it easy to apply an SSL to our JIRA instance.

When I ran into this issue, I rebooted my Bitbucket into "Recovery Mode", so I'm able to log in as recovery_admin to administer the bitbucket server.

I BELIEVE the mechanism that allows bitbucket to log into JIRA is Application links.  This is where I'm going to try and troubleshoot the authentication issue, but both JIRA and Bitbucket have application links pointing back to each other, and both say they're "Connected".  

I've additionally removed the application links and re-added them.  I started in Jira, and I need to authenticate with Bitbucket, I did, and then bitbucket needed to authenticate with Jira.  It all went through fine, but I'm still not able to log into bitbucket with a Jira account.

This was working before I setup the proxy, so I don't anticipate version being a major issue, though I'll list them here:

Jira: 8.18.1
Bitbucket: 4.8.3

I should also mention that I was careful to ensure the link to jira didn't change. It's the same URL, same port, same everthing.  Another thing is my confluence also logs in with jira accounts, and without any changes, it's continuing to log into jira.  

I figure that either I'm looking in the wrong place, like maybe application links have nothing to do with bitbucket authenticating with JIRA, or something is making reference to the IP address of the server.  When setting up the proxy, jira.domain.com needed to resolve to the proxy instead of the server, and the proxy is responsible for directing that traffic to the jira server.  If something is making reference to the jira server directly, that might be the root of the issue.  Or perhaps the proxy is blocking something.

1 answer

0 votes
Preston Morris_ Jr_ June 6, 2023

I figured out my own problem.  It's not an application link, it's a "User Directory" that I needed to update in Bitbucket.  I updated it to reflect the proxy'd URL, and all is well now.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
4.8.3
TAGS
AUG Leaders

Atlassian Community Events