Error pushing large changeset: errno 10054 (forcibly closed by remote host)

I've grabbed an open source web app and wanted to push the entire thing as-is to bitbucket before I start hacking away at it.

TortoiseHg is reporting that the push is 22.7MB. I've tried pushing to https and http (with TortoiseHg and CLI) but in each case I get:

URLError: [Errno 10054] An existing connection was forcibly closed by the remote host

It seems that while individual files are small, the push is too big overall. I've looked for ways of splitting the push (e.g. Kiln has --chunked) but not getting anywhere. The large files extension doesn't seem to be relevant.

Similar to http://stackoverflow.com/questions/13218114/unable-to-push-to-bitbucket-an-existing-connection-was-forcibly-closed-by-the

3 answers

This widget could not be displayed.
Jason Worley Atlassian Team Mar 18, 2013

Greetings,

We have had recent reports of this problem typically from Windows 7 64 bit users. Can you confirm that is your Operating System and version? Also, can you tell me which version of Mercurial or TortoiseHG Workbench you have installed?

The workaround for now will be to switch to SSH. We have a [very thorough guide|https://confluence.atlassian.com/display/BITBUCKET/Set+up+SSH+for+Mercurial] to help get you going fast.

Please let me know if you have any issues setting up SSH.

We are working to identify the cause of this issue and hope to have a resolution soon, but SSH will be what will get you going right now.

Cheers,

Jason | Atlassian

Yes, Windows 7 64bit. Not sure what version of TortoiseHg I was using then, probably 2.6.

Thanks for the response, I ended up committing small chunks of files and pushing them piece by piece - SSH would've been faster.

This widget could not be displayed.

I have the same problem on win 7 64, but switching to ssh drastically slowed down pushing. Bundling one file takes several minutes, while its a second using https. Any workarounds?

This widget could not be displayed.

Use the command line, and use the --chunked option. You still get the same error (at the end of pushing), and it's quite slow, but it works. e.g.

hg --repository d:\src\whatever push --insecure --chunked https://whatever

P.S. I'm using windows 7 64,

tortoisehg version 2.10.1

mercurial version 2.8.1

pushing massive changes is the problem, smaller ones ok.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

1,199 views 8 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you