Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,335
Community Members
 
Community Events
168
Community Groups

Error pushing 2mb+ files after 7.5.0 upgrade

Hi All,

We have been able to push files of 2MB or more previously, but since upgrading to 7.5.0 at the weekend, we are unable to push files over 2MB or so.

We are running behind Nginx proxy (both BB and Nginx are Docker Containers), previously had issues with pushing larger files, so added the Nginx "client_max_body_size" param set to 1024m and that solved all our issues in this area. 

I don't think the issue is at Nginx side as that's had no changes, the only change is the upgrade of Bitbucket from 7.3.2 to 7.5.0

Client-Side we get the error:

POST git-receive-pack (2535946 bytes)
fatal: the remote end hung up unexpectedly
fatal: the remote end hung up unexpectedly

Server Side in Atlassian-bitbucket.log I'm getting:

2020-08-17 10:48:53,409 INFO [http-scmrequest-handler:thread-4] User.Name @30ME3Bx648x976310x0 1 ClientIP,172.22.0.3 "POST /path/to/repo.git/git-receive-pack HTTP/1.0" c.a.s.i.s.g.p.h.GitSmartExitHandler DPT/dpt_2019[1229]: Writ
e request from ClientIP failed due to a socket timeout

I am not aware of any other changes (only I have access to server-side), we have reviewed the workarounds and resolution on https://confluence.atlassian.com/stashkb/git-push-fails-fatal-the-remote-end-hung-up-unexpectedly-282988530.html but the resolution of setting the HTTP post buffer has zero effect on this.

Proxy timeouts all set to 180s (3 minutes) error occurs within one minute usually,

Network wise we are pushing from VMs on the same cluster (same rack) as the Bitbucket server.

Command-line and multiple Git UIs have been used.

We are using HTTP(s) - via the Nginx proxy. SSH is disabled.

Smaller pushes work fine, performance seems good overall.

 

Does anyone know of anything else we could try??

#Help

2 answers

0 votes

We were having the same problem. It took us hours to figure this one out, but eventually we stumbled across this - https://jira.atlassian.com/browse/BSERV-12549

Setting plugin.bitbucket-git.hosting.nio.http=false is what fixed it for us.

It's not answer.

 

I have same problem. 

I also upgraded from 7.2.3 to 7.5.0.

 

I can't push 925k image file.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.5.0
TAGS

Atlassian Community Events