Error in App distribution step in Pipeline integration

Gökmen Bayram February 8, 2023

Hello everyone, when merged with development, the pipelines process starts. I have two steps in Pipelines flow.
1- Detekt
2- Firebase App Distribution.

It completes the Detekt step successfully, but I always get an error on the Firebase App Distrubition step. I don't see a detailed error message in Bitbucket. (As indicated in the picture)

Screen Shot 2023-02-08 at 12.31.23.png

In the picture below, I am sharing the contents of the .sh file that I want to run in the yml file. To see Logs due to error received "./gradlew assembleDebug appDistributionUploadDebug
Even if I close " and run "./gradlew assembleDebug --stacktrace" I get an error and I can't see the error message. What should I do in this situation?

Screen Shot 2023-02-08 at 12.32.46.png

Contents of my .yml file
Screen Shot 2023-02-08 at 12.35.57.png

1 answer

0 votes
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 13, 2023

Hi @Gökmen Bayram,

Have you tried using the --debug or --scan option in the command to get more output?

Kind regards,

Gökmen Bayram February 13, 2023

Hi @Theodora Boudale . Yes, I tried. I saw the logs in the first picture.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events