Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error importing repositories from local account: Request parameter repo_ids must not be empty

Trying to add repositories from local account gives error:

Request parameter repo_ids must not be empty

Capture.PNG

6 answers

1 accepted

0 votes
Answer accepted

Hello @Michael Trullas Garcia ,

Welcome to the Community and thanks for reaching out.

It looks like you haven't selected any repositories to import on the page you saw this modal dialog. That is, every repository has a checkbox there, and you haven't ticked any. Can you confirm this?

I agree Bitbucket rather shouldn't allow to click on Add repositories button unless there's at least one repository selected instead of showing this meaningless error message. I'll add a bug to our backlog to get this fixed.

Hope this helps. Let me know if you have any questions.

Cheers,
Daniil

Hello @Daniil Penkin

Of course I select the repositories. I press the first checkbox to select all the repos. Anyway, I tried to select one repo too and it gives the same error.

Please try it yourself.

Regards.

Yep had same error here. Selected the checkbox when trying to add an existing repo to a project and got the same error.

I'm seeing the same problem

Same error here. It's this a bug?

smae here.  it seems like a bug.

steps below are how i have got error.

 

1. fork some repository 

2. Add repositories from an individual account.  ( forked one )

bitbucket-error.PNG

Same error here. The error was encountered while I'm trying to add an existing repo to a newly created team. I think the 'Add repositories' should also be disabled if there are no repos ticked.

Same here when trying to add repo from an individual account... 

Same error her; @Daniil Penkin any fix yet?

Hey all and @Michael Trullas Garcia,

Thanks for checking this. I confirm it is indeed a bug, I filed a bug in our public issue tracker that you can track. The fix is on the way.

Cheers,
Daniil

Like Michael Trullas Garcia likes this

Hello everyone,

Just letting you know that the fix for this issue has just been deployed, you should be able to use the move/import screens now.

Cheers,
Daniil

Like Michael Trullas Garcia likes this

Adding my name to the list to track this issue. 

I wonder since when this has become a bug, until you fix it, is there a work around?

I did seem to find a workaround:

1. https://bitbucket.org/repo/create

2. Click on Import:

Import.PNG3. enter the required details, once imported, you may delete you old repo

Well, this would rather "copy" the repository.

As I mentioned in the linked ticket, a workaround is to transfer the ownership of a repository:

  • go to repository settings
  • on Repository details tab click Transfer repository
  • select the team in question as target account
  • as a team admin you'll receive an email to accept the transfer – click on the link there
  • in the dialog you'll be able to select the project to put it in

This way you'll preserve all the metadata of the repository like pull requests and comments.

Cheers,
Daniil

Hi everyone! Today is 29/01/2020 and I also have a problem with the same error. Has some bugfix greated or not?

there is a problem - I also confirm

Same problem. Confirmed. Please fixed asap.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Calling any interview participants for Bitbucket Data Center

Hi everyone,  We are looking to learn more about development teams’ workflows and pain points, especially around DevOps, integrations, administration, scale, security, and the related challeng...

477 views 5 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you