We have Bitbucket 5.5.0 running under a dedicated user account (atlbitbcket) on Linux (CentOS 7.x). We now have need to have Elasticsearch running on the server (I can see in the logs it doesn't start up automatically when Bitbucket does) and when I try to go to http://myserver.mydomain.com:7992 it doesn't respond.
I also noticed the following in System Information:
base-url: http://localhost:7992/
username: bitbucket
hasPassword: true
connection-result: AUTHENTICATION_ERROR
So it appears that Elastic Search is trying to start using the user 'bitbucket' instead of 'atlbitbucket'. And there is no user 'bitbucket' defined on my server.
Where can I change these config settings, to have Elasticsearch service attempt to start, by using the user 'atlbitbucket' (with no password), to see if that is the issue?
How do I enable Elasticsearch and how do I get it to run under the same non-privileged user account that my Bitbucket server does?