Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,960
Community Members
 
Community Events
176
Community Groups

EOF Error while uploading commit with bigger files

Hey,

in a project we have a Patcher System which creats builds, patches etc.
For better use I decided to zip the builds, patches etc. These zip files are 2-5 gig in size and will get bigger in the future.

I created commits and uploaded with no real issues. Sometimes I have to push again but in total it uploaded the commit with the bigger files.

Last week I was not able to upload those commits anymore. After some seconds (ca. 30) the upload stops with EOF error. I tried on different days and times (because e.g. friday afternoon the server seem to be very busy) but I'm not able to push such large commits anymore .

I'm using SourceTree and we have a paid workspace with lfs and the zip is in the .gitattributes.
Has something changed? So that you can only upload till a specific commit/file size?

The SourceTree Error message is following:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks -c lfs.customtransfer.bitbucket-media-api.path=git-lfs-bitbucket-media-api push -v --tags origin master:master
Pushing to bitbucket.org:WORKSPACENAME/REPOSITORYNAME.git
Uploading LFS objects: 50% (1/2), 2.3 GB | 132 MB/s, done.
EOF
error: failed to push some refs to 'bitbucket.org:WORKSPACENAME/REPOSITORYNAME.git'
Completed with errors, see above.

Thanks for help in advance.
Cheers

Dans

1 answer

As a short note:
I have seen the post "Git push size limits are coming...." Git-push-size-limits-are-coming-to-Bitbucket-Cloud-starting 

But it should not prevent me from uploading via LFS. Also tried the 'git count-objects -vH' command, this is the result:
$ git count-objects -vH
count: 691
size: 3.09 MiB
in-pack: 9
packs: 1
size-pack: 5.24 KiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events