Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Deployment is not triggered on pull-requests when using bitbucket-pipelines

I am trying to do a deploy when a pull request is merged into the master branch using bitbucket-pipelines however the deploy is not triggered. If I change from pull-requests to branches it does work. 

The bitbucket-pipelines.yml look like:

image: 'ruby:2.4.0'
- step:
name: 'Deploy to production'
deployment: production
- bundler
- 'bundle install'
bundler: ./vendor

Any help is appreciated. 

3 answers

1 accepted

1 vote
Answer accepted
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 01, 2019

Hey @Bram van Dooren,


Thanks for reaching out.

Pipelines that are defined for pull requests will run only if there is a pull request open for the branch defined. i.e. in your example above, the pull-requests pipeline will run when a PR is open from the master branch (not when a PR is merged into the master branch).

Branch pipelines run on every push to the branch, so if you'd like your deployment to run when you merge to master, you should define that as a branch pipeline for the master branch. That way, every push to the master branch will trigger the pipeline and the deployment will run. 

For more information about pull request pipelines, you can check out our documentation

Hope this info helps! 

Hello @Aneita,


Thank you for the clarification, I will use the branch pipeline instead.

Like Aneita likes this

Hello, I ran into this problem as well.
I modified my bitbucket-pipelines .yml this way:

- step:
{script code}

My goal is to trigger pipeline, when someone creates PR into master, but this is not working.
I have tried other combinations, but it still didn't work.

Thanks for any help.

Like # people like this
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 06, 2019

Hey @nickcub,


Thanks for reaching out. Can you please raise a support ticket so that we can look at your repository in more details? 




1 vote
Daniel Santos
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Dec 28, 2018

Hello @Bram van Dooren,

I was able to reproduce a similar scenario with my repository when the bitbucket-pipelines.yml file is not in synch between branches.

We opened a bug report for this problem:

Let's wait for the outcome of our developers on this, but until there, please try to make all bitbucket-pipelines.yml files in synch across branches and that should fix the issue.

Hello @Daniel Santos,

Thank you for your response.

The file bitbucket-pipelines.yml was already in sync across the branches. The issue was as mentioned by @Aneita that I assumed the deployment would be triggered when a pull-request was merged into the master branch.

Daniel Santos
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 02, 2019

Hey @Bram van Dooren, I didn't understand you correctly. I got that you wanted the pull request merging to master, but didn't get that you wanted the trigger only when the merge was happening. Your write was clear, but I managed to understand the way I wanted =|
I'm glad the @Aneita was able to jump in and clarify this for us. At least I was able to find another issue that needed to be reported.

See you in the next thread!

Like Bram van Dooren likes this
0 votes
Myrat Altyyev
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 22, 2023

I had a similar issue. It worked before, but suddenly nothing worked (neither pull-request nor merge).

I had to manually trigger the pipeline (from pipelines menu on the right side press "run pipeline", then select the branch and the pipeline you want to run).

Not sure what the problem is and when it will be solved.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events